Closed Bug 932606 Opened 6 years ago Closed 6 years ago

[l10n][1.2] Bulgarian Keyboard missing

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+, b2g-v1.2 fixed)

VERIFIED FIXED
blocking-b2g koi+
Tracking Status
b2g-v1.2 --- fixed

People

(Reporter: delphine, Assigned: timdream)

References

Details

(Whiteboard: LocRun1.2)

Attachments

(1 file)

Seems like the Bulgarian keyboard is missing on 1.2, although it's a shipping locale
Seen on Buri device, 1.2 Com RIl
Gaia   2ef9bc3c7a6de228b63e6ba3613eb0c0dd639c59
SourceStamp 4a94d2ea9d37
BuildID 20131028004002
Version 26.0a2

Marking as koi? since Bulgarian is a 1.2 requested locale
blocking-b2g: --- → koi?
Flags: needinfo?(rlu)
Assignee: nobody → rlu
Flags: needinfo?(rlu)
Shipping locale.
blocking-b2g: koi? → koi+
Need to grab the layout definition from Android if we don't have one.

We could reference the layout def. from rowkeys_bulgarian[1-3].xml 
https://android.googlesource.com/platform/packages/inputmethods/LatinIME/+/master/java/res/xml/rowkeys_bulgarian1.xml
Comment on attachment 827914 [details] [review]
mozilla-b2g:master PR#13420

Because there is not one in community interested in contribute, I have composed a layout file based on xml layout file in AOSP repo.

Is there a locale owner to needinfo? to for them to verify? If we couldn't get that we would just have to check-in this patch as-is.
Attachment #827914 - Flags: review?(rlu)
Attachment #827914 - Flags: feedback?(lebedel.delphine)
Assignee: rlu → timdream
Status: NEW → ASSIGNED
Hello,

Apparently I misunderstood the email from a few days ago. 

Bulgarians use two layouts when typing in cyrillic - Phonetic and BDS. The first one maps latin to cyrillic letters and the second one is a completely different layout.
I don't know which of both is more used.
The phonetic layout itself has two versions - Traditional and new. The traditional one is more used.

Is there enough time to discuss it with other members of the Bulgarian community or should I go ahead and submit a pull request with both layouts?
(In reply to Mihail Chilyashev from comment #5)

Yes, I read Wikipedia. It looks like there is more than one options for the Bulgarian people.

I am not entirely sure offering these choices in FxOS make more sense than simply copying what AOSP have (one phonetic layout). If you reach a conclusion from the community I am more than happy to take a patch that fill their needs.

In the mean time, we need to get koi+ bug resolved and v1.2 out. So my suggestion is to verify what I did and land it to meet the minimum requirement, and open up another bug to land more layout once we are sure of what to do. Thanks!
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #6)

Let's do it like you say then.
I'll ask around and will open a bug with the new layouts when we reach a decision.

Sorry for the delay.
Attachment #827914 - Flags: feedback?(lebedel.delphine)
Comment on attachment 827914 [details] [review]
mozilla-b2g:master PR#13420

Looks good to me.
Thanks for this patch.


Mihail, thanks for your feedback.
Attachment #827914 - Flags: review?(rlu) → review+
master: https://github.com/mozilla-b2g/gaia/commit/7829c1784e21957da4b82576c3505fb372929c0d
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
This bug is now resolved on master branch.

Mihail, please DO needinfo me on the new bug you filed so I can make sure we get it landed!
I will when it's filed, thanks!
Uplifted 7829c1784e21957da4b82576c3505fb372929c0d to:
v1.2: e8a5bccb4bead3851296bd73c575e10010800c6f
Running through the Keyboard suite in the Localization Screen Pass, the keyboard for Bulgarian appears to be working as intended. Verifying as fixed. 

Here are the environment variables of the device used to test.

Environmental Variables
Device: Buri v1.2 COM RIL
Build ID: 20131203004002
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/244e98241b2c
Gaia: N/A
Platform Version: 26.0
RIL Version: 01.02.00.019.102 
Firmware Version: V1.2_US_20131115
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.