Clicking reply does not obey reply-to header in source message

RESOLVED DUPLICATE of bug 933555

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 933555
4 years ago
4 years ago

People

(Reporter: velPL, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.69 Safari/537.36

Steps to reproduce:

Click Reply button on a message, which has following headers (stripped non-important ones):

Return-Path: <powiadomienia@dominium.pl>
Sender: "Powiadomienia DOMINIUM.PL" <powiadomienia@dominium.pl>
From: "Powiadomienia DOMINIUM.PL" <powiadomienia@dominium.pl>
Reply-To: "iwanttoreplytothisone@example.com" <iwanttoreplytothisone@example.com>
To: powiadomienia@dominium.pl


Actual results:

In compose window I got powiadomienia@dominium.pl in reply to field after clicking Reply on a message with such headers.


Expected results:

Reply to should be set to iwanttoreplytothisone@example.com

This issue happens only in 24.1.0 version. Prior versions react properly

Comment 1

4 years ago
The same here (TB v24.1.0, Win7 pro 64bit). The reply-to entry in the header was shown in the view of the mail, but after clicking on "reply" the from address was used in the new mail.

Comment 2

4 years ago
Same problem here (TB 24.1.0, Linux).

Comment 3

4 years ago
I believe this is the same bug as Bug 933555 - "Reply-to:" broken in Thunderbird 24.1.0
https://bugzilla.mozilla.org/show_bug.cgi?id=933555

Which I am also experiencing. (see comment 6 of above bug )

Comment 4

4 years ago
Yes, as the submitter of 933555 I agree it is a duplicate.

The important things to realize are that

1) The condition which triggers the bug, Thunderbird to ignore "Reply-to:" is that the "From:" address is in the user's address book.  If it is not, then "Reply-to:" is handled correctly.

2) If condition (1) is met, then the address which is erroneously used instead of "Reply-to:" is not "From:" as was stated above, but in fact "To:".  That subtlety is not noticed in cases where "From:" and "To:" are the same.

I hope this sheds some light on this problem.

Comment 5

4 years ago
Excuse me, apparently I mis-stated condition 1 when I wrote:

> 1) The condition which triggers the bug, Thunderbird to ignore "Reply-to:"
> is that the "From:" address is in the user's address book.  If it is not,
> then "Reply-to:" is handled correctly.

I believe that the correct statement is, "If the "From:" address is an identity of mine..."

Discussion in the other bugzilla thread (#9335550zzzzzzzzzzzzzz0 indicates that it is irrelevant whether it is also in the user's address book.

     - Rich

Comment 6

4 years ago
I really wish it were possible to edit comments once posted here.  I hit my "z" key instead of shift:

Discussion in the other bugzilla thread (#9335550) indicates that it is irrelevant whether it is also in the user's address book.

Comment 7

4 years ago
I am experiencing the same issue and it has only occurred since the latest update (24.1.0 release)

Comment 8

4 years ago
see also bug 933555 and bug 933377 which might be dupes (haven't checked yet)
See Also: → bug 933555, bug 933377
Blocks: 699681
(In reply to velPL from comment #0)
> Return-Path: <powiadomienia@dominium.pl>
> Sender: "Powiadomienia DOMINIUM.PL" <powiadomienia@dominium.pl>
> From: "Powiadomienia DOMINIUM.PL" <powiadomienia@dominium.pl>
> Reply-To: "iwanttoreplytothisone@example.com"
> <iwanttoreplytothisone@example.com>
> To: powiadomienia@dominium.pl

From: == Sender: == To: != Reply-To:.
Reply-To-Self case? Is the mail address yours and defined as Identity in your Tb?
Or the mail address is not defined in your Tb as Idenity, and the mail was sent to you as BCC:?
Or the mail is transferred to you by mail transfer service etc, for example "with Resent-To:"?

Note: 
Condition of "If the "From:" address is an identity of mine..." pointed cy Commnt #5, which is discovered in bug 933555, indicaes that Reply-To-Self is relevant and is perhaps a cause.
See deppendency tree for meta bug 699681, please.

Comment 10

4 years ago
I think you may have misunderstand the problem we are seeing.

The "Reply-to-self" is not the issue, we are trying to reply to customers / third parties who's email addresses are in the "Reply-To:" header although the "From:" header contains an email address that is our own, for example the email arrives in our mailbox "sales@camerasunderwater.co.uk" as below:

To: sales@camerasunderwater.co.uk
Subject: Cameras Underwater Ltd
From: Cameras Underwater Ltd <sales@camerasunderwater.co.uk>
Reply-To: Acustomer <acustomer@dummy.com>

When hitting the reply button we find the resulting email is addressed to "sales@camerasunderwater.co.uk" ( which is the "From" address in the original email ) rather than the expected result which is to address the reply to "acustomer@dummy.com" ( which is the "Reply-To" address in the original email. )

Please let me know if you need any further clarification.

Regards,

Adrian

(In reply to WADA from comment #9)
> (In reply to velPL from comment #0)
> > Return-Path: <powiadomienia@dominium.pl>
> > Sender: "Powiadomienia DOMINIUM.PL" <powiadomienia@dominium.pl>
> > From: "Powiadomienia DOMINIUM.PL" <powiadomienia@dominium.pl>
> > Reply-To: "iwanttoreplytothisone@example.com"
> > <iwanttoreplytothisone@example.com>
> > To: powiadomienia@dominium.pl
> 
> From: == Sender: == To: != Reply-To:.
> Reply-To-Self case? Is the mail address yours and defined as Identity in
> your Tb?
> Or the mail address is not defined in your Tb as Idenity, and the mail was
> sent to you as BCC:?
> Or the mail is transferred to you by mail transfer service etc, for example
> "with Resent-To:"?
> 
> Note: 
> Condition of "If the "From:" address is an identity of mine..." pointed cy
> Commnt #5, which is discovered in bug 933555, indicaes that Reply-To-Self is
> relevant and is perhaps a cause.
> See deppendency tree for meta bug 699681, please.

Comment 11

4 years ago
Yes,  Adrian Portway very well describes the exact problem I have been experiencing.
(In reply to Adrian Portway from comment #10)
> I think you may have misunderstand the problem we are seeing.
> 
> The "Reply-to-self" is not the issue, we are trying to reply to customers /
> third parties who's email addresses are in the "Reply-To:" header although
> the "From:" header contains an email address that is our own, for example
> the email arrives in our mailbox "sales@camerasunderwater.co.uk" as below:
> 
> To: sales@camerasunderwater.co.uk
> Subject: Cameras Underwater Ltd
> From: Cameras Underwater Ltd <sales@camerasunderwater.co.uk>
> Reply-To: Acustomer <acustomer@dummy.com>

  To:                           sales@camerasunderwater.co.uk
  From: Cameras Underwater Ltd <sales@camerasunderwater.co.uk>
  Reply-To: Acustomer          <acustomer@dummy.com>

Do you understand what is "Reply-to-self in Tb"?
Do you actually read pointed bug 933555, meta bug 699681, and bugs listed in dependency tree for bug 699681?
The "self" in "Reply-to-self" is "identity defined in Tb" in feature which is named "Reply-to-self" by Tb developer...

Comment 13

4 years ago
Hi, thank you for your reply.

Yes I do understand what "Reply-to-self" in Tb is, just to be sure I have re read the whole of the bug report that you linked to, however neither I, nor anyone else reporting this problem is trying to reply to self, in fact we are trying to reply to a third party who has emailed us.

The third party has a different address in the "Reply-to" header than the one in the "From" header, when replying TB incorrectly uses the "From" address rather than the "Reply-to" address from the original headers. I have experimented with this by using "Reply to all" in TB as well as the standard reply, in both cases TB always creates an email reply addressed to the email address in the "From" header rather than the expected behaviour which is to use the "Reply-to" address of the original email.

I'm not sure how I can make this any clearer.

(In reply to WADA from comment #12)
> (In reply to Adrian Portway from comment #10)
> > I think you may have misunderstand the problem we are seeing.
> > 
> > The "Reply-to-self" is not the issue, we are trying to reply to customers /
> > third parties who's email addresses are in the "Reply-To:" header although
> > the "From:" header contains an email address that is our own, for example
> > the email arrives in our mailbox "sales@camerasunderwater.co.uk" as below:
> > 
> > To: sales@camerasunderwater.co.uk
> > Subject: Cameras Underwater Ltd
> > From: Cameras Underwater Ltd <sales@camerasunderwater.co.uk>
> > Reply-To: Acustomer <acustomer@dummy.com>
> 
>   To:                           sales@camerasunderwater.co.uk
>   From: Cameras Underwater Ltd <sales@camerasunderwater.co.uk>
>   Reply-To: Acustomer          <acustomer@dummy.com>
> 
> Do you understand what is "Reply-to-self in Tb"?
> Do you actually read pointed bug 933555, meta bug 699681, and bugs listed in
> dependency tree for bug 699681?
> The "self" in "Reply-to-self" is "identity defined in Tb" in feature which
> is named "Reply-to-self" by Tb developer...

Comment 14

4 years ago
 Adrian Portway wrote:
> in both cases TB always creates an email reply addressed to the email address in the "From" header
> rather than the expected behaviour which is to use the "Reply-to" address of the original email.

Actually, in my experience, in this case TB addresses the reply to the original "To:" address.
It may seem to use the "From:" address when "From:" and "To:" happen to be the same, but when they differ (and "From" is one of my identities, triggering the bug) it will use the "To:" address instead of either "Reply-To:" or "From:".

Comment 15

4 years ago
(In reply to Adrian Portway from comment #13)
> Yes I do understand what "Reply-to-self" in Tb is, just to be sure I have re
> read the whole of the bug report that you linked to, however neither I, nor
> anyone else reporting this problem is trying to reply to self, in fact we
> are trying to reply to a third party who has emailed us.

Thanks Adrian for trying to figure things out with us.
I think your scenario and the problem you are facing is fully understood, and there's no doubt that the "reply-to" address isn't used when replying.

However, along what WADA and Rich were trying to say but maybe it was not yet understood, it is very possible that there's a *feature* in TB that actually causes your problem, and that feature involves "reply-to-self". Let me try to explain the link between your scenario and that feature.

Most users don't usually write emails to themselves. So *suppose* there's a simple message in your sent folder (I'm aware that this is NOT exactly your scenario):

Original msg:
From: sales@camerasunderwater.co.uk (1)
To: acustomer@dummy.com (2)

On that message, click "Reply". Under normal circumstances, reply means "use original From: sender as To: recipient". So that *would* in theory create the following msg (which it does not in current TB):

Normal reply algorithm (not applicable here, just for demonstration):
From: sales@camerasunderwater.co.uk (or whichever of your accounts the msg belongs to)
To: sales@camerasunderwater.co.uk (1)

However for this scenario, TB notices that the original From: sender (1) of the original message is actually one of your own identities which you have set up in TB, so TB assumes that the odds are 99:1 that you do NOT want to reply to yourself, but you actually want to reply to your customer. So for this particular scenario, TB will try to be smart and exceptionally use the original To: recipient as new To: recipient, assuming that if original From: is yourself, then original To: must be the other party you are communicating with. So the resulting reply (current behaviour of TB) will be (which you might call the "Reply-to-self" scenario, or the "avoid-reply-to-self" feature):

Special reply algorithm for cases of "reply-to-self":
From: sales@camerasunderwater.co.uk (1)
To: acustomer@dummy.com (2)

So for that simple case, this looks like intelligent behaviour (and has actually been requested by users). Now unfortunately the same algorithm will fail in your particular (and somewhat extraordinary) scenario:

Original msg:
From: Cameras Underwater Ltd <sales@camerasunderwater.co.uk> (1)
Reply-To: Acustomer          <acustomer@dummy.com> (3)
To:                           sales@camerasunderwater.co.uk (2)

So from TB's point of view, this message was originally From: yourself (because From: has one of your identities), iow you were the sender. So TB will not use From: as the recipient of the reply, because, per above feature, users don't usually reply to themselves. Reply-to is usually an alternative address provided by *the sender*, so given that From: is your own address, TB will also ignore Reply-to on the assumption that it belongs to you because From: and Reply-to: *usually* refer to the same person/entity, namely the sender (but maybe per this bug, that's not always a correct assumption to make).
So TB will just do the same as in above example, and use the original To: address as new recipient:

From: sales@camerasunderwater.co.uk> (or whichever account the original msg belongs to)
To:                           sales@camerasunderwater.co.uk (2)

Now the tricky part being that the new To: address happens to be your own address again, due to the unorthodox construction of the original mail (and you have to admit your original mail does not look like a typical mail from some original sender to another original recipient). So the net result for your scenario ends up to be exactly what this feature around "reply-to-self" is trying to avoid, namely a "reply-to-self"...

Now from here, we might want to try to make the algorithm smarter somehow (although we'll probably always fail on some funny edge cases...).
(In reply to Adrian Portway from comment #13)
> Yes I do understand what "Reply-to-self" in Tb is, just to be sure I have re
> read the whole of the bug report that you linked to, however neither I, nor
> anyone else reporting this problem is trying to reply to self, in fact we
> are trying to reply to a third party who has emailed us.
As I already wrote, "Reply-to-self in Tb" is "a name of a feature in Tb", and it's absolutely independent from "what you are trying" or "what you expect", except "you are trying to reply to a mail which has some attributes, and a relevant attribute=='mail address is identity in Tb'".
See Tb's code which I pointed in bug 933555 comment #25, and see cited code in bug 933555 comment #27, please.

> The third party has a different address in the "Reply-to" header than the one in the "From" header,
> when replying TB incorrectly uses the "From" address rather than the "Reply-to" address from the original headers.
"TB incorrectly uses the From address rather than the Reply-to" for which?
From: in reply mail? Or To: in reply mail?

First step is "identity selection for From: in reply mail". In this step, "From: header in replied mail" should be used, and Reply-To: header shouldn't be used.
During identity check based on mail headers, isReplyToSelf=true/false is determined.
When isReplyToSelf==true is set by Tb, From: in replied mail is used for From: of reply mail.
After that, Tb chooses mail address for To: in reply mail.
An obvious problem seen in code cited by bug 933555 comment #27 is : 
  Current Tb code never uses Reply-To: header
  if isReplyToSelf==true is result of message header check and identity check.
  If isReplyToSelf==true, current Tb code always uses *To:* header in replied mail
  for To: of reply mail.
Second problem is:
  Because of "From: == To:" in your case,
  it looks for you that From: header in replied mail is used instead of Reply-To: header.

Comment 17

4 years ago
Thank you WADA and Thomas D, it seems like things have been moving a pace over the weekend on bug #933555 which I believe is a duplicate of this one.

It appears I didn't understand that when WADA asked about "Reply-to-self" he was referring to a feature in the code rather than a feature of the program ( a subtle difference which I hadn't grasped when I replied despite thinking I had ). I guess this is the problem we can sometimes have when people from different IT disciplines interact. Sorry if I muddied the waters any.

WADA I have been following your comments on bug #933555 and will use that bug for any further comments.
Reason why I continued analysis in bug 933555 is that who has discovered most important "From: is identity" first is bug opener of that bug and he correctly pointed it in this bug, and that some one continueed to say "this is not Reply-To-All problem" in this bug, and my favarite bug summay was bug summary of that bug :-)
This bug(bug 932774), bug 933555, and bug 933377 are obviously dup, and that bug is already lengthy for reading bug and understandig proble/solution, because I started with wrong assumption and I did some mistakes in creating test case. And, bug opener of that bug says "his problem is duplicate of this bug" since early stage of problem analysis.
So, I believe that we are better to transfer "pretty important items" to this bug from that bug after summarizing and are better to find proper solution in this still crispy bug.
If try&error is needed, or if helping users is needed, we can use that bug for it with keeping this bug readable.
Sorry, typo. "this is not Reply-To-All problem" => "this is not Reply-To-Self problem"
This bug occurs when all following conditions are met.
> Required conditions for "Reply-To: is ignored by Tb" :
>    (i) From: mail address is identity-X
>   (ii) There is only one identity-Y in recipients(To:, CC:, Delivered-To:.
> BCC:?)
>  (iii) identity-Y == identity-X
>   (iv) Mail-Reply-To: or Reply-To: exists
> i.e.
> If From: is not identity, Reply-To: is correctly used as expected.
> If there is no identity in recipent(s), or if multiple identities are
> involved in recipients, Reply-To: is correctly used as expected.
> If identity-Y != idntity-X, Reply-To: is correctly used as expected.
> If no Mail-Reply-To: and no Reply-To:, user can't be aware of this bug.
Status: UNCONFIRMED → NEW
Component: Message Compose Window → Composition
Ever confirmed: true
OS: Windows 8.1 → All
Product: Thunderbird → MailNews Core
Hardware: x86_64 → All

Comment 21

4 years ago
Got the same Problem here and i need a (fast) solution because habitwhise a lot of emails get delivered to me insted zo my customers.

Comment 22

4 years ago
You can try the workaround from: https://bugzilla.mozilla.org/show_bug.cgi?id=933555#c45

Comment 23

4 years ago
Same here TB 24.1.1 W7 ultimate 64bit

Comment 24

4 years ago
Fixing this in bug 933555.
No longer blocks: 699681
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 933555
You need to log in before you can comment on or make changes to this bug.