Closed Bug 933377 Opened 7 years ago Closed 6 years ago

Reply to on some emails does not reply to the reply to address only the sender

Categories

(Thunderbird :: Untriaged, defect)

24 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 933555

People

(Reporter: reds, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

A message is received from our web site order page with the From address of reds@bolerium.com and the Reply to address of the customer say rockyheck@mac.com
We open and read it. Hit Reply To button.
The reply message pops up but the addresses are all reds@bolerium.com. We are replying to our own email and not the customer.
On the other hand we get an email order from order@abebooks.com with a reply to address of rockyheck@mac.com
We open, hit Reply and the reply message is addressed correctly to rockyheck@mac.com.

This bug only occurs on our web site emails and only since we upgraded. Yesterday it was on one computer but I upgraded my computer this morning and now have the same problem


Actual results:

Since we upgraded to 24.1.0.5044 emails from our web site order form (reds@bolerium.com) have a bug related to the Reply To button. Instead of replying to the customer email which is in our Reply To field, the message defaults to the sender address - which is our own address of course. This does not happen on other service emails such as order@abebooks.com where the message goes to the Reply to address and not the Sender address. I have our technician working on our end but it would help if we knew what has changed in the coding for the Reply button. Thanks!

Rocky Heck for John Durham


Expected results:

When we hit Reply button it should reply to the Reply To email address if different from Sender address
See Also: → 932774
I am new to this system and not a programmer. Has there been any progress on this problem? We are now looking at dropping Thunderbird altogether and moving to a cloud email system. Not because of this problem but due to the fact there are several of us using this email account and the right hand never knows what the left hand has done. But until we do we would like to be able to use Thunderbird efficiently. We are constantly replying to ourselves and not our customers. Thanks in advance
No longer blocks: 699681
See Also: → 933555
Have you read bugs pointed in this bug?

Bugs pointed at "See Also:", "Depends on:", "Blocks:" etc. has meaning at here, B.M.O for developers, not support forum nor help center, regardless of "You are new to this system and not a programmer, or not".
And, "pointing other bug in comment" also has meaning such as "read that bug, please", because comment poster never tries to waste his time by "putting absolutely irrelevant bug number in his comment of a bug at B.M.O".
If you need help, instead of "you are trying to help developers to resolve bugs", ask at appropriate place such as support forum, please.

Already pointed bug 932774 is already closed as dup of bug 933555 which I've added to "See Also:" field.
Same problem as already known bug 933555(and its dups), which was already pointed by comment #1, which is already being prcessed by developer?
If different, what is difference of your problem?
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 933555
You need to log in before you can comment on or make changes to this bug.