[travis-ci][meta] Reduce startup costs as much as humanly possible

RESOLVED WONTFIX

Status

Firefox OS
Gaia
P1
normal
RESOLVED WONTFIX
5 years ago
2 months ago

People

(Reporter: lightsofapollo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Currently to run a gaia-ui-test (which uses b2g-desktop, xpchsell, pip packages AND npm paches] it takes around 4 minutes to start the tests. To get to a point where we can run shepherd and allow it to manage all landings we need the overall time for a built to complete to be very low (otherwise our queue will keep stacking up leading to even slower development). Shepherd aside we are looking at 25~ minute build times in the current state and splitting up our builds even further has gains but we loose a ton of vm time simply starting them.

This metabug will track the various optimizations and profiling done to make this fast.
(Reporter)

Updated

5 years ago
Depends on: 932943
(Reporter)

Updated

5 years ago
Depends on: 932946
(Reporter)

Comment 1

5 years ago
Lots of builds running in parallel seen here:

https://travis-ci.org/mozilla-b2g/gaia/builds/13271258
(Reporter)

Updated

5 years ago
Depends on: 932959
(Reporter)

Updated

5 years ago
Duplicate of this bug: 934245

Comment 3

2 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.