Patch for Bug 920230 breaks caldav scheduling

RESOLVED FIXED in 2.6.3

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mguessan, Assigned: mguessan)

Tracking

Lightning 2.6.1
2.6.3

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131025151332

Steps to reproduce:

Accept a meeting request


Actual results:

Email notification instead of Caldav scheduling outbox notification


Expected results:

As Caldav server supports scheduling and calendar.caldav.sched.enabled is enabled, Lightning should use Caldav notifications.

I noticed the following message in console :
CalDAV: principal namespace list empty, calendar XXX doesn't support scheduling

After request:
CalDAV: send: PROPFIND http://localhost:1080/principals/users/user%40company.com/
<?xml version="1.0" encoding="UTF-8"?>
<D:propfind xmlns:D="DAV:" xmlns:C="urn:ietf:params:xml:ns:caldav"><D:prop><C:calendar-home-set/><C:calendar-user-address-set/><C:schedule-inbox-URL/><C:schedule-outbox-URL/></D:prop></D:propfind>

However, according to server logs, the request is sent to:
http://localhost:1080/users/user%40company.com/calendar
=> calendar url instead of principal url

The target uri visible in log statement is computed in caldavCalendar.js around line 2081:
        let requestUri = makeURL(this.calendarUri.prePath + this.ensureEncodedPath(nextNS));

... but actual address is calendar uri (line 2183):
this.sendHttpRequest(this.makeUri(), queryXml, MIME_TEXT_XML, null, (channel) => {

=> should be
this.sendHttpRequest(requestUri, queryXml, MIME_TEXT_XML, null, (channel) => {

I also noticed another bug around line 2752:
            if (this.verboseLogging()) {
                cal.LOG("CalDAV: send(" + requestUri.spec + "): " + uploadData);
            }
            let uploadData = serializer.serializeToString();
            let requestUri = this.makeUri(null, this.outboxUrl);

=> log statement references not yet declared variables
(Assignee)

Comment 1

5 years ago
Created attachment 824915 [details] [diff] [review]
caldav-scheduling-regression.patch

Proposed patch for regression
Comment on attachment 824915 [details] [diff] [review]
caldav-scheduling-regression.patch

Pushing in Philipp's review queue. ;)
Attachment #824915 - Flags: review?(philipp)
Assignee: nobody → mguessan
Blocks: 930207
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Comment on attachment 824915 [details] [diff] [review]
caldav-scheduling-regression.patch

r=philipp, thanks for the patch!
Attachment #824915 - Flags: review?(philipp) → review+
Attachment #824915 - Flags: approval-calendar-release+
Attachment #824915 - Flags: approval-calendar-beta+
Attachment #824915 - Flags: approval-calendar-aurora+
Target Milestone: --- → 2.6.3
Duplicate of this bug: 937845
You need to log in before you can comment on or make changes to this bug.