Closed Bug 933120 Opened 6 years ago Closed 6 years ago

Move HOST_PROGRAM and HOST_SIMPLE_PROGRAMS to moz.build

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla28

People

(Reporter: glandium, Assigned: glandium)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file, 1 obsolete file)

No description provided.
Depends on: 933135
Fixup for HOST_SIMPLE_PROGRAMS.
Attachment #825149 - Flags: review?(gps)
Attachment #825146 - Attachment is obsolete: true
Attachment #825146 - Flags: review?(gps)
Blocks: 933145
Duplicate of this bug: 916929
Comment on attachment 825149 [details] [diff] [review]
Move HOST_PROGRAM and HOST_SIMPLE_PROGRAMS to moz.build

Review of attachment 825149 [details] [diff] [review]:
-----------------------------------------------------------------

Did you want to add the migrated variables to the blacklist in config.mk?

::: js/src/moz.build
@@ +361,5 @@
>      'jskwgen.cpp',
>      'jsoplengen.cpp',
>  ]
>  
> +HOST_SIMPLE_PROGRAMS += [ 'host_%s' % f.replace('.cpp', '') for f in HOST_SOURCES ]

Nit: Cuddle braces.
Attachment #825149 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/53170bea23a6
https://hg.mozilla.org/mozilla-central/rev/abf07d06b712
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Whiteboard: [qa-]
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.