[RFE] Native SMIL Support

RESOLVED WONTFIX

Status

()

Core
XML
--
enhancement
RESOLVED WONTFIX
16 years ago
10 years ago

People

(Reporter: xyzzy, Assigned: dcone (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
With SMIL 1.0 already a W3C Recommendation (http://www.w3.org/TR/REC-smil/), and 
SMIL 2.0 (http://www.w3.org/TR/smil20/) on the way, currently Proposed 
Recommendation, it is about time to consider this enhancement.

While I have yet to get this to work for me in IE 5.5 (perhaps because of 
non-standard implementation?), MS says they do/will support this, so this may 
become an IE parity issue eventually.  W3C Link on this is an abandoned link...

This also may have some bearing on a backend for bug 39245 (Slide Shows).
This looks like a dupe of Bug 76981 (mozilla does not recognize application/smil
type)
(Reporter)

Comment 2

16 years ago
I missed that one somehow, but I think this is different based on the summary 
and the discussion.  The issue on that bug seems to be the recognition of the 
mime type and plug-in support.  I think the upshot of their discussion was that 
it was supported, but by only because of RealPlayer bundling.  In any case, 
leaving this open, revising summary to reflect "native" support, and waiting for 
somebody that knows better to tell me otherwise...
Summary: [RFE] SMIL support → [RFE] Native SMIL Support

Comment 3

16 years ago
not sure who shuold get this but for sure not me.
Assignee: asa → heikki
Component: Browser-General → XML
QA Contact: doronr → petersen
Don might be the best owner for this, reassigning.
Assignee: heikki → dcone
(Reporter)

Comment 5

16 years ago
SMIL 2.0 is now a W3C Recommendation, updated URL.
(Assignee)

Comment 6

16 years ago
I dont think browsers will support the SMIL specification, because this a 
multi-media type application.  What Microsoft does support is HTML + timing 
which is a small part of SMIL.  To do all the things SMIL does would take 
something like the Quicktime player or the Real Player and browsers are not 
going in that direction.  The plugins like the Real Player do support this 
specification, and SVG does support the animation part of the SMIL spec, but I 
doubt a browser in the near term can support this since it would have to be a 
full featured animation engine to do this.  If you want to discuss this I would 
be happy to keep open a thread to go into the issue.  But having sat on the SMIL 
working group for a year I dont see how we could possibly support this except 
partially with HTML+timing (like Microsoft), and through the SVG support of 
animation.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 7

16 years ago
I am happy with the resolution on this, but I did want it considered.  I was
mostly concerned with this being an excuse to not run Mozilla in favor of IE. 
Since they are only supporting a subset (HTML + TIME), perhaps it is more
appropriate to consider that subset for implementation.  It may support the
feature set I was looking for.  I wouldn't know, because of the aforementioned
problem accessing the MS site.

HTML + TIME is another RFE...  I'll file it later if I find out if it will
support what I want, and if it doesn't seem hack-ish.
*** Bug 95919 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

16 years ago
*** Bug 117676 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
Humm.... perhaps I should learn to do a search as well as look at the commonly
asked enhancements...

Anyways, whatever happened to W3C's request for the application/xhtml+xml
mime-type? Which would be used instead of text/html, thus infering that an xhtml
or xml doc should be viewed as an application instead of a text doc? That (in my
deranged mind atleast) would infer some sort of graphics.

As for a plugin, I guess I can agree, and I would be more than willing to write
one... I just need to know one thing... where can I find the Mozilla plugin
docs? I will see if there is another bug asking it. My first idea was to do this
too, make a plugin that either scanned the page for SMIL (and SVG) tags, or an
<img> tag that linked to a SMIL file, but I got discouraged from it after
looking at the docs on Netscape.net, on making plugins which are only upto date
to NS4, and also could do a little bit different approach to to the chapters (A
whole chapter in one html file?!? I would much prefer next/prev buttons, but
thats OT)...
*** Bug 156012 has been marked as a duplicate of this bug. ***

Updated

15 years ago
QA Contact: petersen → rakeshmishra

Comment 12

15 years ago
*** Bug 184221 has been marked as a duplicate of this bug. ***
*** Bug 212394 has been marked as a duplicate of this bug. ***

Comment 14

14 years ago
*** Bug 216462 has been marked as a duplicate of this bug. ***

Updated

14 years ago
QA Contact: rakeshmishra → ashishbhatt
*** Bug 269915 has been marked as a duplicate of this bug. ***

Comment 16

10 years ago
Six years have passed since the opening of this bug, the Web has evolved, and browsers are evolving with it. Flash and Silverlight are technologies that could be replaced with SMIL, in a standard way.

The AMBULANT Player supports SMIL 2.1 and is free software:
http://www.cwi.nl/projects/Ambulant/distPlayer.html

I guess it would be quite easy to use it to add support to SMIL, after asked the author to relicense it.

Please reconsider this bug.
You need to log in before you can comment on or make changes to this bug.