Closed Bug 933380 Opened 6 years ago Closed 6 years ago

shell.getContentWindow is undefined when trying to remotely close an app

Categories

(Core Graveyard :: DOM: Apps, defect)

defect
Not set

Tracking

(firefox26 verified, firefox27 verified, firefox28 verified, b2g-v1.2 fixed)

VERIFIED FIXED
mozilla28
Tracking Status
firefox26 --- verified
firefox27 --- verified
firefox28 --- verified
b2g-v1.2 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

References

Details

Attachments

(1 file, 1 obsolete file)

Bug 924032 regressed the support for remote app closing by using shell.getContentWindow() instead of getContentWindow().
Hopefully we will get that unitested soon.
Attachment #825430 - Flags: review?(fabrice)
Attachment #825430 - Attachment is obsolete: true
Attachment #825430 - Flags: review?(fabrice)
Attachment #825450 - Flags: review+
Attachment #825450 - Flags: review?(fabrice)
Attachment #825450 - Flags: review?(fabrice)
Keywords: checkin-needed
Blocks: 929106
https://hg.mozilla.org/mozilla-central/rev/82546b96471c
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla28
Comment on attachment 825450 [details] [diff] [review]
Fix exception on app close request

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 924032
User impact if declined: Stop action will be broken in app manager
Testing completed (on m-c, etc.): Locally and baked on master a few days.
Risk to taking this patch (and alternatives if risky): limited, only devtools codepath
String or IDL/UUID changes made by this patch: none.

As bug 924032 was uplifted to 1.2, we need to also uplift this to fix its regression.
Attachment #825450 - Flags: approval-mozilla-beta?
Comment on attachment 825450 [details] [diff] [review]
Fix exception on app close request


[Triage Comment]
also approving for aurora (27) uplift since we'll want to cover the bases there, assuming you can land this there as-is.
Attachment #825450 - Flags: approval-mozilla-beta?
Attachment #825450 - Flags: approval-mozilla-beta+
Attachment #825450 - Flags: approval-mozilla-aurora+
Keywords: verifyme
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

The issue still reproduces on Fx 26 beta 7 (20131122094025), latest Aurora (20131125004001) and latest Nightly (20131124104839) when Firefox OS 1.2 Simulator is used - the apps are not stopped.

With Firefox OS 1.3 Simulator and an unagi device with 1.3.0.0-prerelease the issue doesn't reproduce on latest Firefox versions, but today I couldn't reproduced it also on the Nighlty builds from October (when the bug was filled). I have tried with default, hosted and packaged apps.

I remember noticing this issue on device in October and email Paul Rouget about it, he told me when it was fixed and I confirmed it was fixed. I don't understand why now the original issue is not reproducible on those builds.
Alexandre, do you have any suggestions? Thank you
Flags: needinfo?(poirot.alex)
Simulator 1.2 builds are based on a gecko version of the 28th, so it doesn't contains the patch that landed on 6th of Nomvember.
I'll spawn new xpi right now.
Flags: needinfo?(poirot.alex)
Verified as fixed on Fx 26 beta 8 (20131125215016), latest Aurora and latest Nightly on Win 7 64-bit, Ubuntu 13.04 64-bit and Mac OS X 10.8.5.

However, on an unagi device with Fx Os 1.2.0.0-prerelease, the issue still occurs, the apps aren't stopped, no matter what OS or Fx versions are used.
The issue described in comment 12 is no longer reproducible. Removing the verifyme keyword.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.