Closed Bug 933390 Opened 9 years ago Closed 8 years ago

integration tests for -stage and -prod

Categories

(Input Graveyard :: Code Quality, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: willkg, Assigned: willkg)

References

Details

(Whiteboard: u=dev c=tests p=3 s=input.2014q2)

I can't remember if there's a bug for this or not, but it's really important, so I'm writing up another one.

Right now Input has a set of unit tests in the repository alongside the code. When we switched to the new Input, QA stopped maintaining the old Input's QA tests. Those tests are here:

    https://github.com/mozilla/input-tests

Those tests are immensely helpful in catching regressions on the site. Further, we can run those tests in a variety of browsers--something we can't otherwise do right now.

This bug covers the work for going through those tests, writing up issues in that github issue tracker for which ones need to be rewritten/updated and getting the infrastructure/documentation/whatevs so we can be covered by QA wonderfulness and not continue in our playing-with-fire blissful unawareness.
Figured I'd make this a Bugzilla bug because I need to track this unit of work and account for it in my work load and that makes the bookkeeping easier.

Making this a P1 because I should do it pronto.

cc:ing Bob and Stephen so they can see it and comment accordingly.
Assignee: nobody → willkg
Priority: -- → P1
Whiteboard: u=dev c=tests p=2 s=input.2013q4
A few days ago, I went through all the existing tests and wrote up issues for updating the ones I thought needed updating. I totally forgot I wrote up a bug to cover this work. Oops.

Outstanding bits:

getting the infrastructure/documentation/whatevs so we can be covered by QA wonderfulness


I think we'll get there when we've finished updating the tests. Right now if we kick things off, we just get a bunch of failures.
Status: NEW → ASSIGNED
Bunch of tests have been fixed/rewritten. I did a test run against stage and there are a lot of failures, but 3 passes. So this is still in progress.
Pushing the rest off to 2014q1.
Whiteboard: u=dev c=tests p=2 s=input.2013q4 → u=dev c=tests p= s=input.2014q1
Moving this to 2014q2.
Whiteboard: u=dev c=tests p= s=input.2014q1 → u=dev c=tests p= s=input.2014q2
Making this block on bug #970325--we shouldn't be pushing out any more changes to the feedback forms without regression tests.
Blocks: 970325
Did a first pass on tests for generic feedback form. There are probably other things I should be testing, but that's a pretty good minimal batch.

In a PR: https://github.com/mozilla/input-tests/pull/165

Outstanding things:

1. remove or update the rest of the tests for the front page dashboard
2. update tests for the Firefox OS form
This has been a lot of work, so I'm making it a 3 pointer.
Whiteboard: u=dev c=tests p= s=input.2014q2 → u=dev c=tests p=3 s=input.2014q2
Scratch the work in input-tests. I talked with Bob and Ricky and then decided what I want is a set of smoke tests that can be versioned alongside the code they're testing. So I switched gears and created a smoketests/ directory with the stuff I needed.

In a PR: https://github.com/mozilla/fjord/pull/302

Still outstanding:

1. we need to add tests for the Firefox OS form

Plus some cleanup:

1. there's a lot of stuff in the pages/ files that can probably be removed, but it's hard to figure that out without a lot of code grepping
2. we need to rename "feedback" to "dashboard" in a bunch of places where the code is talking about "feedback", but it's really the "dashboard"
3. there's probably some other things we should add tests for that I'm forgetting now
4. there are a few tests that take a while to run because the test code is bumping into implicit waits--we should identify these and remove them; it's probably like 10 seconds of unnecessary pausing per instance
Product: Input → Input Graveyard
You need to log in before you can comment on or make changes to this bug.