Closed Bug 933420 Opened 6 years ago Closed 6 years ago

Bookmark list doesn't update when bookmark title is edited

Categories

(Firefox for Android :: Awesomescreen, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 28
Tracking Status
firefox26 --- unaffected
firefox27 --- verified
firefox28 --- verified
fennec 27+ ---

People

(Reporter: Margaret, Assigned: Margaret)

References

Details

(Keywords: regression)

Attachments

(1 file)

The changes just don't take effect.

Luckily I only see this on Nightly, not Aurora, but it will probably be an issue in Aurora again when updates are re-enabled.
Thought this was bug 907988 which bug 917455 fixed :/
tracking-fennec: ? → 27+
Assignee: nobody → margaret.leibovic
Finally getting around to looking into this. I found that this actually only happens when we edit the bookmark title, and this problem is caused by the fact that we're bailing in TwoLinePageRow.updateFromCursor if the url hasn't changed:
http://hg.mozilla.org/mozilla-central/annotate/4bf430d990e5/mobile/android/base/home/TwoLinePageRow.java#l221

Patch coming soon.
Keywords: regression
Summary: Bookmark list doesn't update when bookmark is edited → Bookmark list doesn't update when bookmark title is edited
Attached patch patchSplinter Review
This restores the original ordering of this logic:
http://hg.mozilla.org/mozilla-central/diff/c83b4d9555bc/mobile/android/base/home/TwoLinePageRow.java#l1.176

rnewman, you reviewed that, so I'll let you review this patch as well :)
Attachment #8341934 - Flags: review?(rnewman)
Comment on attachment 8341934 [details] [diff] [review]
patch

Review of attachment 8341934 [details] [diff] [review]:
-----------------------------------------------------------------

Hm, fair!
Attachment #8341934 - Flags: review?(rnewman) → review+
Comment on attachment 8341934 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 914296
User impact if declined: a bookmark won't appear to update if the user edits its title
Testing completed (on m-c, etc.): just landed on fx-team
Risk to taking this patch (and alternatives if risky): low-risk, small tweak to restoring previous logic ordering
String or IDL/UUID changes made by this patch: none
Attachment #8341934 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/e65afa90bb23
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
Keywords: verifyme
Attachment #8341934 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → VERIFIED
Keywords: verifyme
Verified fixed on:
Build: Firefox for Android 27.0a2 (2013-12-05)
Device: Samsung Galaxy Nexus
OS: Android 4.2.1
You need to log in before you can comment on or make changes to this bug.