NfcWorker to maintain Callback map

RESOLVED WONTFIX

Status

Firefox OS
NFC
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: psiddh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.101 Safari/537.36

Steps to reproduce:

nfc_worker.js does not maintain Callback map. Without this previous callback maybe overriden in some race conditions leading to some undesired behaviours
(Reporter)

Updated

5 years ago
Blocks: 860906
Depends on: 674741

Comment 1

5 years ago
What's this bug used for? What's the impact?
Flags: needinfo?(psiddh)

Updated

5 years ago
Blocks: 937504
(Reporter)

Comment 2

5 years ago
This is 'nice to have' fix in nfc_worker. Also there is an ongoing effort to port nfc_worker.js to its C++ version (not sure of its current status). If the port were to happen at the earliest, then we need not have to fix anything in the java script implementation of the worker (since it would have moved to c++ version anyways).
That said, if we stick to current java script implementation, I would assume that we may have couple of issues in extreme conditions where the DUT (device under test) is subjected to heavy Nfc testing. In a normal testing mode and user scenarios this may not be an issue.
Flags: needinfo?(psiddh)
As the worker will be re-written in C++, close this as WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.