Remove encodeNdefRecords func from NfcContentHelper

RESOLVED FIXED in Firefox 39

Status

Firefox OS
NFC
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: psiddh, Assigned: allstars)

Tracking

unspecified
2.2 S12 (15may)
Dependency tree / graph

Firefox Tracking Flags

(firefox39 fixed)

Details

(Whiteboard: [p=1])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/536.11 (KHTML, like Gecko) Ubuntu/12.04 Chromium/20.0.1132.47 Chrome/20.0.1132.47 Safari/536.11

Steps to reproduce:

This is a current limitation when a DOMString is used in sequences of Moz DOM Objects.
Strings such as 'type', 'id' 'payload' (of MozNdefRecord obj) will not be acccessible to NfcWorker.
Therefore as a workaround exists in the form of  , wrapper intermediate function
(Reporter)

Updated

4 years ago
Blocks: 860906
Depends on: 674741

Updated

4 years ago
Blocks: 937504
(Assignee)

Updated

4 years ago
Assignee: nobody → allstars.chh
(Assignee)

Comment 1

4 years ago
It's because nsFrameMessageManager can't create structure clone of MozNDEFRecord.
Assignee: allstars.chh → nobody
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Comment 2

4 years ago
This seems to be the same limitation sending a MozNDEFRecord from App to App via Activity. If so, I'll open a bug, unless that won't be implemented. Then we should consider sending a dictionary object across.
(Assignee)

Comment 3

3 years ago
Given I have implemented Structured Clone for NDEF in Bug 1138886, I'll fix this once I also fix Bug 1139830.
Assignee: nobody → allstars.chh
Status: RESOLVED → REOPENED
Depends on: 1139830
Ever confirmed: true
Resolution: WONTFIX → ---
(Assignee)

Comment 4

3 years ago
Created attachment 8573187 [details] [diff] [review]
Patch.
(Assignee)

Updated

3 years ago
Attachment #8573187 - Flags: review?(dlee)

Updated

3 years ago
Attachment #8573187 - Flags: review?(dlee) → review+
(Assignee)

Comment 5

3 years ago
https://hg.mozilla.org/integration/b2g-inbound/rev/91d92c8be936
Whiteboard: [p=1]
Target Milestone: --- → 2.2 S12 (15may)
https://hg.mozilla.org/mozilla-central/rev/91d92c8be936
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago3 years ago
status-firefox39: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.