Closed Bug 933787 Opened 9 years ago Closed 9 years ago

B2G MMS: Cannot send the second MMS after sending one

Categories

(Firefox OS Graveyard :: RIL, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: airpingu, Assigned: airpingu)

References

Details

(Keywords: regression)

Use 11/1 central/master codes.

Steps:

1. Send out an MMS successfully.
2. Wait for more than 30 seconds.
3. Send the second one.
4. The sending circle will keep spinning. -> KO

Reproducing rate: 100%

Note that the symptom is different from bug 931348.
The last harmful patch changing NetworkManager is Bug 920551. I'm wondering the root cause is that.

Vicamo, what do you think?
Flags: needinfo?(vyang)
Hi Julien, just asking if it's possibly due to Gaia's any recent change?
Flags: needinfo?(felash)
(In reply to Gene Lian [:gene] (needinfo? encouraged) from comment #1)
> The last harmful patch changing NetworkManager is Bug 920551. I'm wondering
> the root cause is that.

Sadly, I wouldn't really have time looking into that until next Tuesday (I have a day-long activity on Monday).

Could Ctai or someone please look at this?
Cannot be a Gaia bug.
Flags: needinfo?(felash)
Yep this seems unlikely :)
QA Contact: sarsenyev
I was not able to reproduce this issue on the Buri with the latest 11/01 central 1.3 build,
I used AT$T and T-Mobile card for the test
The second MMS with an interval more than 30 sec has been successfully sent without any errors on 2G, 3G, 3G+ and WiFi 
Even after trying repro steps from bug:931348, clicking OK button without any changes in the Messaging Settings, all MMS have been successfully sent without any issues

Could you provide more info to help to reproduce this issue, what phone is used?, what SIM card is used?

Device: Buri v1.3 central 
BuildID: 20131101040203
Gaia: ccdf357ea150fc7d8b8a4b74c7adf31e7a57e465
Gecko: abe6790a5dd8
Version: 28.0a1
Firmware Version: US_20131015
Flags: needinfo?(vyang)
Resetting needinfo flag
Flags: needinfo?(vyang)
(In reply to Gene Lian [:gene] (needinfo? encouraged) from comment #1)
> The last harmful patch changing NetworkManager is Bug 920551. I'm wondering
> the root cause is that.

No.  You should find all it does is to wrap some lines with #ifdef...#endif, and these preprocessor guards have no effect in B2G builds with RIL.
Flags: needinfo?(vyang)
(In reply to sarsenyev from comment #6)
> I was not able to reproduce this issue on the Buri with the latest 11/01
> central 1.3 build,
> I used AT$T and T-Mobile card for the test
> The second MMS with an interval more than 30 sec has been successfully sent
> without any errors on 2G, 3G, 3G+ and WiFi 
> Even after trying repro steps from bug:931348, clicking OK button without
> any changes in the Messaging Settings, all MMS have been successfully sent
> without any issues
> 
> Could you provide more info to help to reproduce this issue, what phone is
> used?, what SIM card is used?
> 
> Device: Buri v1.3 central 
> BuildID: 20131101040203
> Gaia: ccdf357ea150fc7d8b8a4b74c7adf31e7a57e465
> Gecko: abe6790a5dd8
> Version: 28.0a1
> Firmware Version: US_20131015

Thanks for you detailed testings! Really appreciate! However, I can still reproduce this bug by the latest HG central codes:

changeset:   153213:396e59370945
tag:         qparent
parent:      153164:6c97dc583b5d
parent:      153212:1cd17b9be3e1
user:        Wes Kocher <wkocher@mozilla.com>
date:        Fri Nov 01 20:34:44 2013 -0700
summary:     Merge inbound to m-c

I used Unagi with Chungwa SIM (a Taiwan local carrier).
Bug 931699 causes the regression. Just backed it out. I'll double check before closing this bug.
Depends on: 931699
Since bug 931699 has been backed out, close this bug as WORKSFORME.

Thanks QA very much for the time testing!
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
blocking-b2g: 1.3? → ---
Assignee: nobody → gene.lian
You need to log in before you can comment on or make changes to this bug.