Closed Bug 933898 Opened 8 years ago Closed 8 years ago

[Camera] 1.3 Visual refresh of Heads Up Display (flash and front/rear toggle buttons)

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect, P1)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED
1.3 Sprint 4 - 11/8

People

(Reporter: pla, Assigned: wilsonpage)

References

Details

(Whiteboard: ux-tracking, visual design, jian)

Attachments

(2 files)

Add functionality for toggling between flash modes:
Flash: On, Flash: Off, Flash: Auto

User Story:

Media 64
As a user, I like to see flash (on, off, auto) as a camera setting.

Version 0.5 Camera Spec:
https://app.box.com/files/0/f/1211601585/1/f_11402480095
Priority: -- → P1
This is the visual spec for the Flash toggle functionality.

Diego, please let me know if you need clarification on any item.
Where can I find the icon?
Attachment #827483 - Flags: review?(tiff)
Attachment #827483 - Flags: review?(dmarcos)
The icons were exported as part of the zip file attached to the overall refresh bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=933893
Assignee: dmarcos → wilsonpage
Comment on attachment 827483 [details]
_Camera1_VisualSpec-FlashV1_Nov5.png

Something I just realized that isn't specified here or in my spec is what happens to the text when in landscape. Do we assume it would be directly to the left or right of the icon?
Attachment #827483 - Flags: review?(tiff) → review+
(In reply to Tiffanie Shakespeare from comment #4)
> Comment on attachment 827483 [details]
> _Camera1_VisualSpec-FlashV1_Nov5.png
> 
> Something I just realized that isn't specified here or in my spec is what
> happens to the text when in landscape. Do we assume it would be directly to
> the left or right of the icon?

The flash icon will remain in the top left whether the screen is in landscape or portrait, so I assume the text will be to the right of the icon at all times.
(In reply to Wilson Page from comment #5)
> (In reply to Tiffanie Shakespeare from comment #4)
> > Comment on attachment 827483 [details]
> > _Camera1_VisualSpec-FlashV1_Nov5.png
> > 
> > Something I just realized that isn't specified here or in my spec is what
> > happens to the text when in landscape. Do we assume it would be directly to
> > the left or right of the icon?
> 
> The flash icon will remain in the top left whether the screen is in
> landscape or portrait, so I assume the text will be to the right of the icon
> at all times.

It's true, the icon remains in the same place on screen no matter the phone orientation. In portrait, the icon is in the top left. When rotating counter clockwise to landscape, this relatively puts the icon in the bottom left with the text still written to the right. But when rotating clockwise, this puts the icon in the top right. 

Since there's no room to the right of the icon for the text, I'm guessing we would put the text to the left of the icon instead of below the icon. Sorry I wasn't more clear with my comments. 

Is this correct Peter? I think either you or I should outline this in a spec to ensure everyone is on the same page.
Flags: needinfo?(pla)
Ahhhh, I completely understand now, sorry. I got confused because the camera app orientation is locked. Yes, I would assume the text should flip to the left hand side when necessary :)
Summary: [Camera] 1.3 Add flash functionality → [Camera] 1.3 Visual refresh of Heads Up Display (flash and front/rear toggle buttons)
Blocks: 933893
Assignee: wilsonpage → wilsonpage
Attached file Pull Request
Attachment #831053 - Flags: review?(dmarcos)
Attachment #831053 - Flags: review?(dmarcos) → review+
Patch looks good to me
Depends on: 937941
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 925215
Yes that makes sense.
Flags: needinfo?(pla)
Attachment #827483 - Flags: review?(dmarcos) → review+
Flags: in-moztrap?(mozillamarcia.knous)
You need to log in before you can comment on or make changes to this bug.