Modern Theme doesn't get packaged anymore ("Missing file(s): bin/extensions/modern@themes.mozilla.org.xpi")

RESOLVED FIXED in seamonkey2.25

Status

SeaMonkey
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Marco Perez, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

Trunk
seamonkey2.25
regression

SeaMonkey Tracking Flags

(seamonkey2.24 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 826172 [details] [diff] [review]
correct FINAL_TARGET path in moz.build for suite's modern theme

Current nightly builds can't be configured to use the modern theme. This option is simply not available from the menu. When trying to create a SeaMonkey package the build fails telling that the corresponding xpi package for the modern theme can't be found.

I suspect this to happen on all platforms but haven't found any bugs yet. I'm not too happy to hard-code the path in moz.build but I haven't found a way to use a pre-defined build variable for e.g. $(DIST). In the meantime this attachment may serve as a band-aid patch.

Updated

5 years ago
Duplicate of this bug: 934087
To add a bit of info to this bug:
For quite a few days now (not sure since when) the Windows SeaMonkey builds fail in the packaging step:
========= Started 'python2.7 e:/builds/slave/c-cen-t-w32-dbg/build/build/pymake/make.py ...' failed (results: 2, elapsed: 10 secs) (at 2013-11-01 23:23:52.319317) ==========
'python2.7' 'e:/builds/slave/c-cen-t-w32-dbg/build/build/pymake/make.py' 'package'
[...]
e:/builds/slave/c-cen-t-w32-dbg/build/objdir/mozilla/_virtualenv/Scripts/python.exe e:/builds/slave/c-cen-t-w32-dbg/build/mozilla/toolkit/mozapps/installer/packager.py -DOSTYPE=\"WINNT5.2\" -DOSARCH=WINNT -DNO_NSPR_10_SUPPORT -DAB_CD=en-US -DMOZ_APP_NAME=seamonkey -DPREF_DIR=defaults/pref -DJAREXT= -DENABLE_TESTS=1 -DMOZ_ANGLE_RENDERER=1 -DMOZ_D3DCOMPILER_DLL=D3DCompiler_43.dll -DMOZ_DEBUG=1 -DMOZ_PACKAGE_DEBUGQA=1 -D_MSC_VER=1600 -DMOZ_URL_CLASSIFIER=1 -DMOZ_UPDATER=1 -DNECKO_WIFI=1 -DMOZ_MSVC_REDIST=1600 -DMOZ_SHARED_MOZGLUE=1 -DWIN_OR_OS2=1 -DMOZ_CHILD_PROCESS_NAME=plugin-container.exe -DDLL_PREFIX= -DDLL_SUFFIX=.dll -DBIN_SUFFIX=.exe -DBINPATH=bin \
	--format omni \
[...]
Error: e:\builds\slave\c-cen-t-w32-dbg\build\objdir\suite\installer\package-manifest:367: Missing file(s): bin/extensions/modern@themes.mozilla.org.xpi

This broke sometime between 21th and 30th of October, cannot narrow this down more exactly via official builds as other build errors occurred during that time.
Summary: Modern Theme doesn't get packaged anymore → Modern Theme doesn't get packaged anymore ("Missing file(s): bin/extensions/modern@themes.mozilla.org.xpi")
Another possibility would be to copy the Makefile rules from classic theme: http://mxr.mozilla.org/comm-central/source/suite/themes/classic/Makefile.in I've asked in Bug 931017 regarding $(DIST).

Comment 4

5 years ago
(In reply to Frank Wein [:mcsmurf] from comment #3)
> Another possibility would be to copy the Makefile rules from classic theme:
> http://mxr.mozilla.org/comm-central/source/suite/themes/classic/Makefile.in
> I've asked in Bug 931017 regarding $(DIST).

As proposed by Neil in a thread in mozilla.dev.apps.seamonkey i am using

-FINAL_TARGET = 'dist/bin/extensions/modern@themes.mozilla.org'
+DIST_SUBDIR = 'extensions/modern@themes.mozilla.org'
(Assignee)

Comment 5

5 years ago
Created attachment 826290 [details] [diff] [review]
Use DIST_SUBDIR instead

Since FINAL_TARGET used to be defined in terms of $(DIST) it should have been converted to DIST_SUBDIR in the first place.
Assignee: nobody → neil
Attachment #826172 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #826290 - Flags: review?(Pidgeot18)
Attachment #826290 - Flags: review?(Pidgeot18) → review+
Pushed patch to get builds working again: https://hg.mozilla.org/comm-central/rev/7551898bf269
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.25
Comment on attachment 826290 [details] [diff] [review]
Use DIST_SUBDIR instead

[Approval Request Comment]
Regression caused by (bug #): Bug 931017
User impact if declined: No modern theme in SeaMonkey builds
Testing completed (on m-c, etc.): Works fine on trunk
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: -

Patch needs to land on aurora as well as Bug 931017 landed before the uplift.
Attachment #826290 - Flags: approval-comm-aurora?

Comment 8

5 years ago
Comment on attachment 826290 [details] [diff] [review]
Use DIST_SUBDIR instead

a=me comm-aurora as well as anywhere else needed.
Attachment #826290 - Flags: approval-comm-aurora? → approval-comm-aurora+
Pushed to aurora: https://hg.mozilla.org/releases/comm-aurora/rev/40b649bdc4d7
status-seamonkey2.24: --- → fixed
You need to log in before you can comment on or make changes to this bug.