UX, OS X: window buttons and fullscreen button wiggle or squish when resizing window or exiting fullscreen mode

RESOLVED FIXED in mozilla28

Status

()

Core
Widget: Cocoa
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Gijs, Assigned: mstange)

Tracking

unspecified
mozilla28
All
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:P2][Australis:M?])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 826185 [details]
Screencast

See screencast.

Happens as of Nov. 1st nightly (first nightly with the window buttons moved). 

Apologies for the not-so-great-screencast, but it's late and I'm fighting Maverick's new quicktime screencasting and can't be bothered. The effect is still pretty visible. Wonder if this is maverick-specific. Can people reproduce on older versions of OS X?
(Reporter)

Updated

4 years ago
Summary: UX: window buttons and fullscreen button wiggle when resizing window → UX, OS X: window buttons and fullscreen button wiggle when resizing window
I also noticed the overlapping/squished controls on Mavericks but I don't remember if I had resized the window first. They didn't redraw properly until I hovered over the buttons and even then there was graphical corruption above the window controls.
Blocks: 851652
No longer depends on: 851652
Keywords: polish
Hardware: x86 → All
(Assignee)

Comment 2

4 years ago
I can reproduce on 10.8.
Assignee: nobody → mstange
Status: NEW → ASSIGNED

Comment 3

4 years ago
Bug 940134 has a simple test case.
(Assignee)

Comment 4

4 years ago
Created attachment 8335286 [details] [diff] [review]
patch

I should have realized this when we started using [cell drawWithFrame:inView:] instead of [view drawRect:] for drawing the window buttons - the rects we pass here have different meanings. In drawRect, the rect can be any subrect of the view's bounds, and the view will then only draw the parts of itself that intersect with this subrect, but it won't change its appearance based on the rect. With drawWithFrame, however, the rect describes the whole size of the cell, so making it smaller will squish the contents or make them overflow. When we only want to draw a subrect of a cell, we need to use a clip on the drawing context.
Attachment #8335286 - Flags: review?
(Assignee)

Updated

4 years ago
Duplicate of this bug: 940134
(Assignee)

Updated

4 years ago
Duplicate of this bug: 936033
(Assignee)

Updated

4 years ago
Attachment #8335286 - Flags: review? → review?(smichaud)
(Assignee)

Updated

4 years ago
Summary: UX, OS X: window buttons and fullscreen button wiggle when resizing window → UX, OS X: window buttons and fullscreen button wiggle or squish when resizing window or exiting fullscreen mode
Comment on attachment 8335286 [details] [diff] [review]
patch

Nice catch!
Attachment #8335286 - Flags: review?(smichaud) → review+
FWIW, I saw this same issue after a restart to my first Nightly build with Australis. Granting focus to the window caused the buttons to redraw as expected.
(Assignee)

Comment 9

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/3caa5f7ef94f
Duplicate of this bug: 941077
https://hg.mozilla.org/mozilla-central/rev/3caa5f7ef94f
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
(Reporter)

Updated

4 years ago
Duplicate of this bug: 936046
(Assignee)

Updated

4 years ago
Blocks: 942170
You need to log in before you can comment on or make changes to this bug.