browser.tabs.onTop does nothing in Australis 28.0a1

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: Robert.Zenz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131028112903

Steps to reproduce:

The option for having tabs on top optionally has been removed from the context menu of the toolbars. The option in about:config still lingers on if you upgrade an existing profile.


Actual results:

The option in about:config "browser.tabs.onTop" is still there if you upgrade a profile, but the context menu item is gone. This will confuse users which are aware of this option as the functionality has been completely removed compared to only the checkbox was removed.


Expected results:

Either reimplement the functionality to have tabs on the bottom or remove the option from about:config on upgrade.
Thanks for the report Robert.

(In reply to Robert Zenz from comment #0)
> The option for having tabs on top optionally has been removed from the
> context menu of the toolbars. 

This was actually removed a long time ago in Firefox 15 if tabs on top was enabled (bug 755646) but Australis removed the context menu for the opposite direction.

> The option in about:config still lingers on if
> you upgrade an existing profile.

The option should only remain there if it was set to a non-default value ("false" in this case). This is intentional in order to preserve the user's choice so that extensions can continue to check the pref to re-implement the old functionality.

> The option in about:config "browser.tabs.onTop" is still there if you
> upgrade a profile, but the context menu item is gone. This will confuse
> users which are aware of this option as the functionality has been
> completely removed compared to only the checkbox was removed.

The preference was removed from the default set of preferences but about:config will show values for non-default preferences and that's what you're seeing. If you right-click on the browser.tabs.onTop pref, and choose Reset, it will disappear.

If it's gone from the context menu, the message should be fairly clear that tabs on bottom is no longer built-in IMO.
Blocks: 755593
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Component: Untriaged → Tabbed Browser
OS: Linux → All
Hardware: x86 → All
Resolution: --- → WONTFIX
Version: 28 Branch → unspecified
Duplicate of this bug: 985455

Comment 3

5 years ago
Australis just landed in beta 29. I find the drop of this feature very disturbing, as the accent is put on Australis being customizable, but ends up being a big regression on this customisation feature for me. (I hope there will soon be some compatible add-ons to re-implement it).

> If it's gone from the context menu, the message should be fairly clear 
> that tabs on bottom is no longer built-in IMO.
Well I thought it was a bug at first ... I guess I won't be the only one.

Anyway, mozilla might want to update https://support.mozilla.org/en-US/kb/put-tabs-back-on-bottom
user-doc-needed to update the documentation in comment 3.

(In reply to philsummer from comment #3)
> (I hope there will soon be some compatible add-ons to re-implement it).

The good news is that they already exist:
* https://addons.mozilla.org/en-US/firefox/addon/tabs-on-bottom/
* or for a bigger hammer, try https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/
Keywords: user-doc-needed
Keywords: user-doc-needed
You need to log in before you can comment on or make changes to this bug.