[Messaging] Tapping on '+' to add a contact to a message shows the contact list with the keyboard

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: isabelrios, Assigned: rwaldron)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 826737 [details]
2013-11-04-08-43-31.png

master 11/04 build:
Gecko-2a1cf31
Gaia-3641a8d

STR
There should be some contacts in the contact list

1. Open Messaging app and create a new message
2. Tap on '+' icon to add a recipient from contact list

EXPECTED
The contact list is shown fine

ACTUAL
The keyboard is active and shown with the contact list. It dissapears and the screen is shown correctly when tapping on it to scroll down the contact list.
Please see screenshot attached.
triage: regression 1.3+
blocking-b2g: 1.3? → 1.3+
Keywords: regression
This is happening from the Activity, so Im wondering if this is something related with System & Keyboard... (because when tapping on '+' icon, we launch the activity 'pick' of Contacts, so the snapshot is within the context of 'Contacts App').
This could be related to bug 920546 too, I remember we had some keyboard problems that we fixed but maybe not all.

Asking qawanted to know if that happens in 1.2.
Keywords: qawanted
Rudy, do you thing that it could be something related with the Keyboard? Is there any bug related?
Flags: needinfo?(rlu)
QA Contact: ckreinbring
Unable to repro on Buri 1.2 commercial RIL.  While the keyboard sometimes persists as the contact list is loading, it always disappears once the list is done loading.

Build ID: 20131107004003
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/26f1e160e696
Gaia: 590eb598aacf1e2136b2b6aca5c3124557a365ca
Platform Version: 26.0
RIL Version: 01.01.00.019.281
Keywords: qawanted
Ok so it might still be bug 920546, but since the keyboard changed between 1.2 and 1.3, it might manifest differently.

Rick, would you have an idea ?
Flags: needinfo?(waldron.rick)
(Assignee)

Comment 7

5 years ago
(In reply to Julien Wajsberg [:julienw] from comment #6)
> Ok so it might still be bug 920546, but since the keyboard changed between
> 1.2 and 1.3, it might manifest differently.
> 
> Rick, would you have an idea ?

No, but maybe Corey (he's been working on Keyboard)
Flags: needinfo?(waldron.rick) → needinfo?(gnarf37)
From my test, the "To" field would be focused after clicking on the [+] button.
You could see that you could input some text into this field, after you dismissed the "pick contact" activity (though the "To" field is covered by the activity).

I suspect the is an issue in Message app itself, does bug 920546 change anything about focus() or element z-index or something?
Sorry that I don't have enough time to dig into that bug, seems like a big one. :)
Flags: needinfo?(rlu)
That's why I asked Rick initially ;-)

But Rudy, once we change an app using an activity, why would the focus still be in the SMS app ?
(Assignee)

Updated

5 years ago
Assignee: nobody → waldron.rick
Hrm - When the window changes to the contacts app it should not care where the focus is in messaging, however explicitly bluring before sending the activity should help solve this.

Perhaps it is some race condition where the keyboard starts to open because of the focus in the recipients area, and then as contacts loads so does the keyboard and doesn't get un-loaded.  Seems a tricky one to try to track down.
Flags: needinfo?(gnarf37)
(Assignee)

Updated

5 years ago
Summary: [Contacts][messaging] Tapping on '+' to add a contact to a message shows the contact list with the keyboard → [Messaging] Tapping on '+' to add a contact to a message shows the contact list with the keyboard
hey Rudy, see comment 9.

I think we can (and will) workaround in the SMS app, but I also think there is a bug in the keyboard handling.
Flags: needinfo?(rlu)
Yes, it seems opening an activity with an input is still focused would cause this issue.
I have created a really simple test case here,
https://github.com/RudyLu/gaia/commit/57354b0253c9c65713ce4ed9dff1a1c40dd34b7d
, which will focus an input and then call the "pick contact" activity.

Could someone confirm this is exactly the same case?
Why would "recipients area" is still focused after clicking [+], is it focused by explicitly invoking focus()?

Thanks.
Flags: needinfo?(rlu)
I found that I could not reproduce this in v1.1, so will create a bug seems Comment 13 looks like a regression in Gaia system/keyboard.

Thanks.
Comment on attachment 829576 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/13534

r=me with the jshint fixes
Attachment #829576 - Flags: review?(felash) → review+
(In reply to Rudy Lu [:rudyl] from comment #13)
> Yes, it seems opening an activity with an input is still focused would cause
> this issue.
> I have created a really simple test case here,
> https://github.com/RudyLu/gaia/commit/
> 57354b0253c9c65713ce4ed9dff1a1c40dd34b7d
> , which will focus an input and then call the "pick contact" activity.

That looks like it, except it's probably a little more asynchronous in our case. You can try adding a setTimeout to your focus. But well it's probably the same thing.

> 
> Could someone confirm this is exactly the same case?
> Why would "recipients area" is still focused after clicking [+], is it
> focused by explicitly invoking focus()?

Rudy, exactly.

We're gonna workaround here but I think it warrants another bug :)
(Assignee)

Comment 17

5 years ago
gaia@master https://github.com/mozilla-b2g/gaia/commit/ea9d190230d3c37d391e5bfabf15997d142f0361
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
flagging rudy for creating a bug about comment 13 and comment 16
Flags: needinfo?(rlu)
Yes, it is Bug 937487.
Sorry that I did not make a explicit. comment.
Flags: needinfo?(rlu)
(Reporter)

Comment 21

5 years ago
Now tapping on '+' to add a contact does not show the contact list with the keyboard active.
Verified with master 11/19 build:
Gecko-59d46a4
Gaia-fa29c2b
Status: RESOLVED → VERIFIED

Updated

5 years ago
Duplicate of this bug: 944036
Duplicate of this bug: 951493
You need to log in before you can comment on or make changes to this bug.