Shumway doesn't work on private browsing window.

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
5 years ago
3 years ago

People

(Reporter: tetsuharu, Unassigned)

Tracking

Details

[env]
http://hg.mozilla.org/mozilla-central/rev/b4143e04bea1

[step to reproduce]
1. Set `shumway.disabled` as `false`.
2. Open some pages which has plugin contents in the private browsing window.

[result]
* Firefox doesn't start shumway.
* Firefox ignore click-to-play, so Firefox would start plugins *automatically* instead of trying start up shumway.
Enable shumway in private browsing window:
https://github.com/mozilla/shumway/pull/930
Blocks: 1038057
Duplicate of this bug: 1080811
Do we care about private browsing support for the Facebook video player?
Summary: Shumway doesn't work on private browing window. → Shumway doesn't work on private browsing window.
Whiteboard: [shumway:fb2?]
Good question. It seems slightly absurd to use Facebook in private browsing mode, but then again what do I know?

We have to look into the whole LSO/data persistence stuff very thoroughly in any case, so this will be a part of that, I guess.
Make bugs with "[shumway-fb2]" whiteboard tag block shumway-fb2 meta bug 1110300.
Blocks: 1110300
Blocks: 1120590
No longer blocks: 1110300
Blocks: 1140984
No longer blocks: 1038057, 1120590
Whiteboard: [shumway:fb2?]
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.