Limited selection of keyboard layouts by default gaia build config

RESOLVED DUPLICATE of bug 1050574

Status

defect
RESOLVED DUPLICATE of bug 1050574
6 years ago
5 years ago

People

(Reporter: alefteris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 years ago
:: Steps To Reproduce

Download latest v1.2 build from http://downloads.geeksphone.com and flash it.

:: Expected Result

Be able to use keyboard layouts from at least regions that will/have shipped Firefox OS devices.

:: Actual Result

I can enable the keyboard layout of 5 additional languages only, apart from English: Portuguese, Spanish, German, French and Polish.

This is the relevant line in gaia's Makefile:

GAIA_KEYBOARD_LAYOUTS?=en,pt-BR,es,de,fr,pl

:: Thoughts

The current list of languages is too limited as the default config and will require people wanting to do testing to build gaia on their own instead of using the ones from geeksphone. I think that the default build config should at least enable layouts for countries that will have shipped devices for 1.2.
Reporter

Updated

6 years ago
See Also: → 934184
-> djf
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(dflanagan)
This is happening also on today's latest v1.2 Com RIL.
Therefore nominating for koi?
blocking-b2g: --- → koi?
Nevermind. Axel will update the bug as to why this is happening.
blocking-b2g: koi? → ---
This is by design, see https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS/Hacking_Firefox_OS/Customizing_the_keyboard

I guess people should file bugs on the individual build configs with proposed changes. Not sure which avenue is best for gp.

Updated

6 years ago
Flags: needinfo?(dflanagan)
Thanks Axel!  Do you feel that we can resolve this as a WONTFIX?

Thanos: Does geeksphone have a way to report bugs? My patch that introduced this change was not coordinated with them. It sounds like they should update their build process to include a longer list of keyboards.
Reporter

Updated

6 years ago
Flags: needinfo?(gp)

Comment 6

6 years ago
(In reply to David Flanagan [:djf] from comment #5)
> Thanks Axel!  Do you feel that we can resolve this as a WONTFIX?
> 
> Thanos: Does geeksphone have a way to report bugs? My patch that introduced
> this change was not coordinated with them. It sounds like they should update
> their build process to include a longer list of keyboards.

David, could you point us to your patch or commit so we can take a look?

Thanks
Flags: needinfo?(gp) → needinfo?(dflanagan)
(In reply to Geeksphone from comment #6)
> David, could you point us to your patch or commit so we can take a look?

That would be bug 884752
https://github.com/mozilla-b2g/gaia/pull/13106
Flags: needinfo?(dflanagan)

Comment 8

6 years ago
But this is in master, not in 1.2. Is this patch merged in 1.2 where the problem is?

Here are the manifest we use: http://www.geeksphone.com/manifests/index.php

As you can see we are using http://git.mozilla.org/ to build gaia, so all the commits merged there are in our images.

Comment 10

6 years ago
Thanks.

Yes, there is no problem to add a biger list of layouts. We will work on it.

To contact us for this kind of things contact us in our forums, by example: http://forum.geeksphone.com/index.php?topic=5743.0

I will take a look of what layouts we could add. Any suggestions?
I would suggest, as I did on the forum, adding ar :-)
No doubt Firefox OS aimed the the MEA region, So for development purposes this is very needed for me now :-)
Reporter

Comment 12

6 years ago
bug 905292 seems to track the required languages for Firefox 1.2, so it would be nice if the keyboards for those languages is enabled in geeksphone's builds.

Comment 13

6 years ago
For master and 1.2 we have added all the layouts that are in gaia/keyboard/layouts. We are building the image right now, if there is no problem with the size it will remain this way.

Comment 14

6 years ago
(In reply to Geeksphone from comment #13)
> For master and 1.2 we have added all the layouts that are in
> gaia/keyboard/layouts. We are building the image right now, if there is no
> problem with the size it will remain this way.
I just flashed my Keon with latest 1.2: images-keon-v1.2-2013-11-12.Gecko-51602f9.Gaia-20e8d40 but I do not see Catalan keyboard. What keyboards you mean with "that are in gaia/keyboard/layouts"?

On a related note, I do not understand the policy of letting third parties select keyboard separately from locale. For example, who would select "Catalan" in the welcome screen and would not expect to have the Catalan keyboard layout installed by default? I think it locale selection and keyboard layout should be somehow linked. What is the point of having a build that lets you select Catalan as locale but does not include the Catalan keyboard and dictionary? [substitute Catalan for any language affected]
Am I missing something?
(In reply to Jordi Serratosa from comment #14)

> What keyboards you mean with "that are in gaia/keyboard/layouts"?
https://github.com/mozilla-b2g/gaia/tree/v1.2/keyboard/layouts

> On a related note, I do not understand the policy of letting third parties
> select keyboard separately from locale. For example, who would select
> "Catalan" in the welcome screen and would not expect to have the Catalan
> keyboard layout installed by default? I think it locale selection and
> keyboard layout should be somehow linked. What is the point of having a
> build that lets you select Catalan as locale but does not include the
> Catalan keyboard and dictionary? [substitute Catalan for any language
> affected]

This seems strange. Do you see the Catalan keyboard in Settings->Keyboards?

Comment 16

6 years ago
Exactly, i add the layouts in https://github.com/mozilla-b2g/gaia/tree/v1.2/keyboard/layouts to the GAIA_KEYBOARD_LAYOUTS variable, but i'm getting errors about "layout not found". This happens with jp-kanji by example. There is any list of supported layouts or any way to see which layouts are working without the need to try and error?

By now in the Geeksphone images only the default layouts will be added until we get a official list.
The point is to be able to add keyboards for which you don't add the localization, or don't have it.

We talked about having logic for "all", but we didn't implement that in the first iteration of the patch.

The following layouts seem to be broken on 1.2:

cs jp-kanji mk 

the buildlog looks something like

echo "$BUILD_CONFIG" > /src/fxos/gaia/build/config.js
XULrunner directory: xulrunner-sdk-26/xulrunner-sdk
run-js-command  applications-data
Looking for packaged app: /src/fxos/gaia/external-apps/marketplace.firefox.com/update.webapp
make: *** [applications-data] Error 3


I'm testing with

for l in `ls keyboard/layouts/|awk -F. '{print $1;}'`;do echo $l; DEBUG=1 GAIA_KEYBOARD_LAYOUTS=$l make;echo $l;echo;echo;done > /tmp/full-log

Comment 18

6 years ago
Exactly the same error.

I will just add all the layouts but this three.

The "all" logic its a step forward, but we must be carefull with the broken layouts and skip them if breaks the building.
I'll file a bug and attach a patch for the brokken layouts.
Filed bug 938052 to fix the layouts.

Comment 21

6 years ago
(In reply to Francesco Lodolo [:flod] from comment #15)
> > 
> > What keyboards you mean with "that are in gaia/keyboard/layouts"?
> https://github.com/mozilla-b2g/gaia/tree/v1.2/keyboard/layouts
I see "ca" is there.

(In reply to Francesco Lodolo [:flod] from comment #15)
> This seems strange. Do you see the Catalan keyboard in Settings->Keyboards?
No, I don't see Catalan in Keon build (latest 1.2 available from 2013-11-12). Do you see it?

(In reply to Axel Hecht [:Pike] from comment #17)
> The point is to be able to add keyboards for which you don't add the
> localization, or don't have it.
Ok, I understand. But I think that the logic should be to add the keyboards layouts for at least as many locales as the build contains (provided that there is a layout available for said locales). Then, if some extra layouts (non-locale related) are need, that could be specified in addition.
For example: 
- Make build with locales: en, ca, pt-br, es
- Is there a specific keyboard layout for en, ca, pt-br, es?Yes: Add it to build

Comment 22

6 years ago
Sorry, pressed the wrong button. I was not done:
For example: 
- Make build with locales: en, ca, pt-br, es
- Is there a specific keyboard layout for en, ca, pt-br, es?
Yes -> Add it to build
No -> Do we need extra keyboards?
Yes -> Specify it additionally.
No -> Build.
Should be a dup to bug 1050574 if we are not talking about specific config on the Geeksphone side.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1050574
You need to log in before you can comment on or make changes to this bug.