Include all keyboards in nightly production builds

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
Last year

People

(Reporter: kosmodrey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

I downloaded last nightly production build from Mozilla's ftp server: http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central-flame/ and installed following guide from wiki: https://developer.mozilla.org/en-US/Firefox_OS/Developer_phone_guide/Flame#Updating_your_Flame_to_a_nightly_build Last


Actual results:

In last nightly 1.4, 2.0 and master versions there are only eight specific keyboards.


Expected results:

I expected to see all available keyboards in nightly production builds.
Not possible until we have bug 1029951 fixed.
Depends on: 1029951

Updated

5 years ago
Depends on: 1053388
Duplicate of this bug: 1053388
I have reduced the scope of bug 1029951 to Latin IME dictionaries only. After that lands, if we change the config of nightly builds to

GAIA_KEYBOARD_PRELOAD_DICT_LAYOUTS=(some layout we want to preload dict) GAIA_KEYBOARD_LAYOUTS=* make

we will ship all layouts.

The problem is that "*" will also ship all Asian IMEs, and they will always build with their dictionary included. So to fit into the same disk space we will have to ship less Latin IME dictionaries. Not sure if that's acceptable since the current preload layouts (w/ dictionaries) are "en,pt-BR,es,de,fr,pl,zh-Hans-Pinyin,en-Dvorak".

Also, switching config with GAIA_KEYBOARD_PRELOAD_DICT_LAYOUTS imply shipping bug 1029951, something not yet for production until UX said so.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
Depends on: 877648

Updated

5 years ago
No longer depends on: 877648
Reporter

Updated

5 years ago
Duplicate of this bug: 1053465

Updated

5 years ago
Blocks: 1096057
I have filed bug 1128396 to list what we need before enabling all "latin"-imengine based layouts on Nightly. Asian layouts still needs their dictionaries preloaded and we would attack that on other depending bugs (not filed yet).

Getting close!
Actually, not Latin-IMEngine based layouts, but all layouts w/o a dictionary or doesn't need a preloaded dictionary.

Comment 9

4 years ago
See also: https://bugzilla.mozilla.org/show_bug.cgi?id=1145991 and comments! Duplicate of this?
And also what are solutions (automatically solution-  not manually flashing!)?
(In reply to Raul Malea from comment #9)
> And also what are solutions (automatically solution-  not manually
> flashing!)?

I am not really following your question here, but if you are asking the proposed solution to bug 1145991, yes, the solution is here, i.e. getting all layouts shipped and have dictionaries available on CDN.

Comment 12

4 years ago
Thank you for working on this bug. Can you please give me instructions on how to test this and give feedback. Thanks! 

I usually follow the instructions in this page. 
https://developer.mozilla.org/en-US/Firefox_OS/Phone_guide/Flame/Updating_your_Flame
Flags: needinfo?(timdream)
The next Nightly build will include bug 1029951 if everything goes smoothly. If you can't wait you can pull Gaia repo manually and do |APP=keyboard make install-gaia|, but that would require a permission refresh which can be complex.

A few Asian IMEs and Handwriting pad will be worked on under this bug... but not immediately. (assign myself as backlog of this work)
Assignee: nobody → timdream
Flags: needinfo?(timdream)
Unassign myself due to project changes.
Assignee: timdream → nobody
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.