Video tearing if disabled HWA in "Get Add-ons"-Page

RESOLVED DUPLICATE of bug 934674

Status

()

RESOLVED DUPLICATE of bug 934674
5 years ago
5 years ago

People

(Reporter: alice0775, Assigned: mattwoodrow)

Tracking

({regression})

Trunk
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox26 unaffected, firefox27 affected, firefox28 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 827531 [details]
screenshot

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/770de5942471
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 ID:20131105030206
http://hg.mozilla.org/releases/mozilla-aurora/rev/be1b50532970
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20131105004004

Video tearing if disabled HWA on "Get Add-ons"-Page

setting gfx.content.azure.enabled = false fixes the problem


Steps To Reproduce:
1. Open about:addons
2. Click "Watch the Video" button in "Get Add-ons"

Actual Results:
Video tearing at the top
(Reporter)

Comment 1

5 years ago
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/1e33678f89fe
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20130920190924
Bad:
http://hg.mozilla.org/mozilla-central/rev/a2c31dc69ab3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20130920193025
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1e33678f89fe&tochange=a2c31dc69ab3


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/44952b2191fc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20130920023238
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/e844f4ed3e1f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 ID:20130920025128
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=44952b2191fc&tochange=e844f4ed3e1f

In local build:
Last Good: ad266fafd429
First Bad: e844f4ed3e1f

Regressed by:
e844f4ed3e1f	Matt Woodrow — Bug 907926 - Enable Azure content for windows. r=nrc
Blocks: 907926
tracking-firefox27: --- → ?
tracking-firefox28: --- → ?
(Reporter)

Updated

5 years ago
Summary: Video tearing if disabled HWA on "Get Add-ons"-Page → Video tearing if disabled HWA in "Get Add-ons"-Page
(Reporter)

Comment 2

5 years ago
Graphics
--------

Adapter Description: ATI Radeon HD 4300/4500 Series
Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM: 512
ClearType Parameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 50
Device ID: 0x954f
DirectWrite Enabled: false (6.1.7601.18245)
Driver Date: 4-29-2013
Driver Version: 8.970.100.1100
GPU #2 Active: false
GPU Accelerated Windows: 0/1 Basic
Vendor ID: 0x1002
WebGL Renderer: Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: false
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Comment 3

5 years ago
Same with Nvidia card.
(Assignee)

Updated

5 years ago
Assignee: nobody → matt.woodrow
(Assignee)

Comment 4

5 years ago
I'm pretty sure this is a duplicate of bug 934674
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 934674
Not tracking this as we are tracking a DUp with similar scenario in 934674
status-firefox26: --- → unaffected
status-firefox27: --- → affected
status-firefox28: --- → affected
tracking-firefox27: ? → ---
tracking-firefox28: ? → ---
You need to log in before you can comment on or make changes to this bug.