add getAssertion (and getKeys) to FxAccounts.jsm

VERIFIED DUPLICATE of bug 909967

Status

VERIFIED DUPLICATE of bug 909967
5 years ago
5 years ago

People

(Reporter: warner, Assigned: warner)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-])

(Assignee)

Description

5 years ago
We need to clean up and enhance the FxAccounts object to allow callers to get signed assertions (for an audience of their choosing) from it.

I (warner) will probably land the "getKeys" functionality at the same time, even though FxOS doesn't specifically need this (Sync does).
(Assignee)

Updated

5 years ago
Summary: add getAssertion to FxAccounts.jsm → add getAssertion (and getKeys) to FxAccounts.jsm
Whiteboard: [qa-]
This is now in the candidate patch in Bug 935232.
Blocks: 935232
No longer blocks: 935245
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
This bug is covered by the working being done in bug 935232.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 935232
OK. This is a [qa-] but I'mma gonna Verify it anyways...
Status: RESOLVED → VERIFIED
Sorry I got the wrong bug. It should be covered by the latest patch in bug 909967.
Duplicate of bug: 909967
You need to log in before you can comment on or make changes to this bug.