Return early in _fillTrailingGap if we're not overflowing to avoid unnecessary work

RESOLVED DUPLICATE of bug 1364661

Status

()

Firefox
Tabbed Browser
--
minor
RESOLVED DUPLICATE of bug 1364661
5 years ago
a year ago

People

(Reporter: MattN, Unassigned)

Tracking

({perf})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:P-][Australis:M-])

(Quoting Matthew N. [:MattN] from bug 899867 comment #7)
> Created attachment 790091 [details] [diff] [review]
> Part 2 - v.1 - Early return in _fillTrailingGap if we're not overflowing
> 
> If we don't flush layout from getting the tabstrip's width (e.g. part 1 /
> attachment 783498 [details] [diff] [review]), then _fillTrailingGap ends up
> causing us to flush.
> 
> It seems like _fillTrailingGap doesn't need to do anything if we aren't
> overflowing since I believe that means we aren't scrolling either. I haven't
> tested this yet so it's possible that the overflow attribute is not set in
> time when narrowing the window. i.e. I need to check the ordering of the
> resize and overflow events.

I haven't had time to investigate if this has an impact on our benchmarks after changes like bug 905695.

If someone wants to steal this from me, feel free. This fix isn't Australis-specific.
Assignee: MattN+bmo → nobody
Status: ASSIGNED → NEW
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1364661
You need to log in before you can comment on or make changes to this bug.