[B2G][MMS] MMS has to be manually downloaded even though Auto-retrieve is enabled when using a roaming sim

RESOLVED INVALID

Status

Firefox OS
RIL
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: KTucker, Assigned: Gene Lian (I already quit Mozilla))

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:koi+, b2g18 unaffected, b2g-v1.2 affected)

Details

(Whiteboard: burirun3)

Attachments

(2 attachments)

Created attachment 827679 [details]
Autoretrieve.txt

Description:
MMS has to be manually downloaded even though Auto-retrieve is enabled when using a roaming sim. 

Repro Steps:
1)  Updated Buri to Build ID: 20131103004003
2)  Insert a roaming sim into thte test device from another country. For test purposes we are using a sim from Taiwan in the US.
3)  Tap on the "Settings" icon.
4)  Tap on "Cellular & Data".
5)  Turn on "Data roaming".
6)  Tap on "Message settings".
7)  Tap on the drop down under Auto-retrieve and set it to "On with roaming" and then tap "OK".
8)  From another device send the test phone a MMS. 

Actual:
The notification of a MMS is received but the attachment is not automatically downloaded. The user has to tap on "download" to receive the MMS.

Expected:
The MMS is downloaded automatically. 

Environmental Variables
Device: Buri v 1.2.0 Mozilla RIL
Build ID: 20131103004003
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/eec4da1b27eb
Gaia: cb981e2f47bc644b4d178d54378c3676c946facf
Platform Version: 26.0

Notes:
Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/runtests/run/2528/env/347/?&pagenumber=1&pagesize=100&sortfield=order&sortdirection=asc&filter-id=8253&filter-id=8252&filter-id=8251&filter-id=8250&filter-id=8249&filter-id=8248&filter-id=8247&filter-id=8246&filter-id=8245&filter-id=8257&filter-id=8258&filter-id=8259&filter-suite=259
See attached: logcat
(Reporter)

Updated

4 years ago
status-b2g18: affected → unaffected
This issue does not reproduce on Leo v 1.1.0 COM RIL

Environmental Variables
Device: Leo v 1.1.0 COM RIL
Build ID: 20130715070218
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/6062fdf2deb8
Gaia: 55ed5e08a2250ea2d3571fff860c39e66fabed14
Platform Version: 18.1
RIL Version: 01.01.00.019.158 

The MMS is automatically downloaded.
Keywords: regression, regressionwindow-wanted

Updated

4 years ago
blocking-b2g: --- → koi?
koi+ for regression.

There is clearly a bug that has landed and caused several other regressions.
blocking-b2g: koi? → koi+

Updated

4 years ago
QA Contact: sparsons

Comment 3

4 years ago
I was unable to reproduce this issue on Buri 1.2 Build ID: 20131106004004

When an MMS is received, a message in Chinese appears (see screenshot attached) with no download button. After that, the user can no longer receive an MMS. 


Gaia   2140c987fdde1c99097018f7e93b0bbd43d2125d
SourceStamp 6a831fcb96f4
BuildID 20131106004004
Version 26.0

Comment 4

4 years ago
Created attachment 828263 [details]
2013-11-06-13-34-18.png
(In reply to Sarah Parsons from comment #3)
> I was unable to reproduce this issue on Buri 1.2 Build ID: 20131106004004
> 
> When an MMS is received, a message in Chinese appears (see screenshot
> attached) with no download button. After that, the user can no longer
> receive an MMS. 
> 
> 
> Gaia   2140c987fdde1c99097018f7e93b0bbd43d2125d
> SourceStamp 6a831fcb96f4
> BuildID 20131106004004
> Version 26.0

That sounds like a separate bug then this - this is talking about the case when auto-retrieve is enabled when MMS is received.
Looks like a RIL issue.
Component: Gaia::SMS → RIL
Flags: needinfo?(gene.lian)
(Assignee)

Comment 7

4 years ago
As far as I know, we didn't land patches to V1.2 for MMS recently. Let me check it out.
Assignee: nobody → gene.lian
Flags: needinfo?(gene.lian)
(Assignee)

Comment 8

4 years ago
(In reply to Sarah Parsons from comment #3)
> I was unable to reproduce this issue on Buri 1.2 Build ID: 20131106004004
> 
> When an MMS is received, a message in Chinese appears (see screenshot
> attached) with no download button. After that, the user can no longer
> receive an MMS. 

It sounds a separate issue (i.e. the download notification doesn't show up). The screenshot is asking you to go to a web to download that MMS. Is that screenshot an kind of SMS? I *guess* some carriers won't send notifications (the one with download button) to you if you're roaming.

I'd appreciate if QA can help dig out the regression window.

Updated

4 years ago
QA Contact: sparsons → nkot

Comment 9

4 years ago
Tony, 
Did you ever get a chance to get the phone number (650-933-6966) activated for long distance activities?
Flags: needinfo?(tchung)
(In reply to Angela Hubenya from comment #9)
> Tony, 
> Did you ever get a chance to get the phone number (650-933-6966) activated
> for long distance activities?

Ccing Ann Ignacio from IT.   she's been helping with getting this setup.
Flags: needinfo?(tchung) → needinfo?(aignacio)

Comment 11

4 years ago
A 300MB Data Global Add On Package has been added to 650-933-6966.
Flags: needinfo?(aignacio)

Comment 12

4 years ago
There is general issue with receiving MMS using roaming SIM, see bug 935287  - whether it's a device issue or SIM... we have only one roaming SIM in our office so i cannot test it any further.

This bug is about "Auto retrieve" and it turned out that if "On with roaming" set properly (have to tap "OK" twice - in menu and in Settings app) the actual result as written cannot be reproduced. It then falls to default setting which is "On without roaming" and the results are following:

1. "On with roaming" setting:
- there would be NO notification for received MMS, the message will appear in Messages app as a new messages and when selected it will keep spinning which is covered in bug 935287

2. "On without roaming" setting: 
- I see the result described here - when notification arrives and it says "Message is not downloaded yet"  which is I believe due to a bug 935287

Having said that, this bug is either WorksForMe, or Invalid, or Dup of bug 935287 or needs to wait for clarification on bug 935287 :)

Have tested on today's 1.2 and on the build this bug was initially reported on, and confirmed these observations with reporter.
So I don't entirely follow comment above - are you saying you can't reproduce the original bug when you made sure on with roaming was on? What is causing on without roaming to be set? I need better clarity on what the bug is here that's being seen here.
Flags: needinfo?(nkot)

Comment 14

4 years ago
Sorry if it was not clear,

The STR as written are incomplete - to set "Auto retrieve" to "On with roaming" the user has to confirm it by tapping "OK" in Settings app not only in Auto retrieve menu, if failed to do that the Auto retrieve will return to default which is "On without roaming"

That means the actual result described in this bug is observed when we have "On without roaming"

 - the user receives MMS notification which states that "Message is not downloaded yet" and since we have a bug 935287 that prevents device to download MMS at all, no matter what we'll set in Setting it will never be loaded... so this message should be expected, and it's not a bug
Flags: needinfo?(nkot)
Closing this out then - sounds like the behavior we saw was expected, so this is invalid.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: regression, regressionwindow-wanted
Resolution: --- → INVALID
(Assignee)

Comment 16

4 years ago
(In reply to nkot from comment #14)
> Sorry if it was not clear,
> 
> The STR as written are incomplete - to set "Auto retrieve" to "On with
> roaming" the user has to confirm it by tapping "OK" in Settings app not only
> in Auto retrieve menu, if failed to do that the Auto retrieve will return to
> default which is "On without roaming"

That OK button is really redundant... I don't know why we came up with that UI.
You need to log in before you can comment on or make changes to this bug.