[first run] connecting to hidden Wi-Fi network fails

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
6 months ago

People

(Reporter: aryx, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

Boot2Gecko 1.2.0.0-prerelease 20131104224010 on Keon, update channel 'default'

After factory reset and also while just running the First Run app, I don't succeed to connect to a hidden Wi-Fi network (haven't tested with SSID broadcasting networks).

Steps to reproduce:
1. Launch First Run app from Settings > Device Information > More Information > First Run app.
2. When you get to the Wi-Fi screen, choose to connect to a hidden network, enter the SSID and the password (it uses WPA-PSK here).

Actual result:
Connecting never succeeds.

Expect result:
Connecting succeeds like when performed from the Settings app.
The content of /data/misc/wifi/wpa_supplicant.conf differs when adding a hidden network from the First Run app compared to the Settings app:


First Run:

ctrl_interface=DIR=/data/system/wpa_supplicant GROUP=wifi
update_config=1
wfd_session_mgmt_ctrl_port=554
wfd_device_max_throughput=10

network={
	ssid="MySSID"
	psk="MyPassword"
	key_mgmt=WPA-PSK
	priority=1
}


Settings:

ctrl_interface=DIR=/data/system/wpa_supplicant GROUP=wifi
update_config=1
wfd_session_mgmt_ctrl_port=554
wfd_device_max_throughput=10

network={
	ssid="MySSID"
	scan_ssid=1
	psk="MyPassword"
	key_mgmt=WPA-PSK
}
blocking-b2g: --- → 1.3?
Does this reproduce on 1.1?
Keywords: qawanted
This doesn't reproduce on 1.1 because the feature landed for 1.2, see bug 824366.

Updated

5 years ago
blocking-b2g: 1.3? → 1.3+
Keywords: qawanted → regression
Fernando,

Please check if you can take this issue.
Flags: needinfo?(fernando.campo)
Keywords: regression → qawanted

Updated

5 years ago
Keywords: qawanted → regression

Updated

5 years ago
Keywords: regressionwindow-wanted
Sorry, right now I'm unable to take it :(

Maybe in a few days, so it depends on the urgency
Flags: needinfo?(fernando.campo)

Updated

5 years ago
QA Contact: mvaughan

Comment 6

5 years ago
This issue reproduces on the first 1.2 build from 06/21/13. Therefore this is not a regression since this build is when the feature landed.

Environmental Variables:
Device: Buri v1.2 MOZ RIL
BuildID: 20130621031231
Gaia: e2f19420fa6a26c4287588701efaec09a750dba1
Gecko: 7ba8c86f1a56
Version: 24.0a1
Firmware Version: V1.2-device.cfg
Keywords: regression, regressionwindow-wanted
Not a regression - per comment #6 this is also not working in 1.2. We didn't block that release on it so we should not block this release on it.
blocking-b2g: 1.3+ → 1.3?
(In reply to Dietrich Ayala (:dietrich) from comment #7)
> Not a regression - per comment #6 this is also not working in 1.2. We didn't
> block that release on it so we should not block this release on it.

Sounds good to me. Moving to blocking-
blocking-b2g: 1.3? → -

Comment 9

5 years ago
+1 (as I was about to file the same bug), indeed experiencing this ever since 1.2 and up.

It might be related to the fact that there is an OK button in the top right when doing this from within Settings, but a Connect button during FTU (in master - I believe this is a little different in previous versions), so something might go wrong with accepting or sending the password. Unfortunately I wasn’t able to verbose logging from an access point in order to see what (or rather if a) password string is sent.
blocking-b2g: - → backlog
Whiteboard: [systemsfe][priority]
Whiteboard: [systemsfe][priority] → [systemsfe], [priority]
Duplicate of this bug: 1011447
This still reproduces on Master (2.0.0-pre) builds on various devices.
Component: Gaia::First Time Experience → Wifi
Whiteboard: [systemsfe], [priority]
(Assignee)

Updated

4 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog

Comment 12

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.