Crash in [@ ReportErrorRunnable::ReportError ]

VERIFIED FIXED in Firefox 28

Status

()

defect
--
critical
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Aleksej, Assigned: khuey)

Tracking

(Blocks 1 bug, {crash, regression, testcase})

Trunk
mozilla29
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox27 unaffected, firefox28 verified, firefox29 verified)

Details

(Whiteboard: [bugday-20131106], crash signature)

Attachments

(2 attachments)

Steps to reproduce:
1. Install the extension, restart.
2. Open test1:test

Firefox crashes.
bp-31c35202-2649-483c-80aa-550bd2131106
bp-ac6e1447-7772-46f6-a52e-c69ef2131106
bp-5b3a5885-5b99-4352-af47-fc8fe2131106

WFM: 2013-11-05-03-02-06-mozilla-central-firefox-28.0a1.en-US.linux-x86_64 770de5942471
Bug: 2013-11-06-03-02-00-mozilla-central-firefox-28.0a1.en-US.linux-x86_64 9ba3faa35c96

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=770de5942471&tochange=9ba3faa35c96
Whiteboard: [bugday-20131106]
(In reply to Aleksej [:Aleksej] from comment #1)
> https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=770de5942471&tochange=9ba3faa35c96

Can you try to narrow this down further using tinderbox builds?
(In reply to Aleksej [:Aleksej] from comment #3)
> https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2ada3a06d5e7&tochange=8b89e6626298

I'm seeing several worker related changes here. Kyle do you know what might have caused this?
Flags: needinfo?(khuey)
Probably one of my changes where I rewrote a good chunk of worker code.
Assignee: nobody → khuey
Flags: needinfo?(khuey)
Summary: Crash with this extension → Crash in [@ ReportErrorRunnable::ReportError ]
Crash Signature: [@ ReportErrorRunnable::ReportError ] → [@ ReportErrorRunnable::ReportError ] [@ (anonymous namespace)::ReportErrorRunnable::ReportError ]
This affects Windows and OS X too.
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: x86_64 → All
Posted patch PatchSplinter Review
What the old code was doing doesn't really make any sense, so lets not even try to do it.
Attachment #8343450 - Flags: review?(bent.mozilla)
Attachment #8343450 - Flags: review?(bent.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/4d4fca3fba59
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Comment on attachment 8343450 [details] [diff] [review]
Patch

This is a regression introduced in 28.  Let's take the fix on Aurora.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 928312
User impact if declined: Possible crashes when using hte web worker API
Testing completed (on m-c, etc.): On m-c, simple patch.
Risk to taking this patch (and alternatives if risky): Low risk.
String or IDL/UUID changes made by this patch: None.
Attachment #8343450 - Flags: approval-mozilla-aurora?
Depends on: 949800
Depends on: 949353
Attachment #8343450 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Aleksej, does this reproduce for you anymore?
Flags: needinfo?(deletesoftware+moz)
Reproduced on nightly 2013-11-07.
Verified fixed 29.0a1 (2013-12-18), win 7 x64
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:28.0) Gecko/20100101 Firefox/28.0
Mozilla/5.0 (X11; Linux i686; rv:28.0) Gecko/20100101 Firefox/28.0

Reproduced the initial issue on nightly 2013-11-07, verified as fixed on latest Aurora 28.0a2 (buildID: 20140103004002).
Status: RESOLVED → VERIFIED
Verified by the people above. Thanks.
Flags: needinfo?(deletesoftware+moz)
You need to log in before you can comment on or make changes to this bug.