Closed Bug 935935 Opened 8 years ago Closed 8 years ago

<title> and <desc> accessibility API mappings reversed

Categories

(Core :: SVG, defect)

25 Branch
x86_64
Windows 8
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 868789

People

(Reporter: faulkner.steve, Unassigned)

References

(Blocks 1 open bug)

Details

In acc API mapping in Firefox the SVG <title> element populates the accessible descritpion property and the SVG <desc> element populates the accessible name property for an <SVG> element

This appears to be the reverse of what it should be as the <title> is commonly meant to provide a brief description and the <desc> element for a longer description. (see example in http://www.w3.org/TR/SVG/struct.html#DescriptionAndTitleElements) Also IE maps the title to acc name and the desc to acc description.

see test case and results here: https://dl.dropboxusercontent.com/u/377471/SVG/adobesimplesvgtest1.html
Blocks: svga11y
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 868789
You need to log in before you can comment on or make changes to this bug.