Closed Bug 936392 Opened 6 years ago Closed 6 years ago

[Flatfish] Unable to set wallpaper by using photos from gallery

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+)

RESOLVED FIXED
blocking-b2g 1.3+

People

(Reporter: atsai, Assigned: gduan)

References

Details

(Whiteboard: [Flatfish][developer+])

Attachments

(1 file)

As a user, I cannot select a photo from gallery to be the wallpaper.

STR:
1. long press on Homescreen
2. select Gallery
3. Try to tap on a photo to select.

Expected Result:
*. show prompt to ask for setting as wallpaper

Actual Result:
*. Nothing happen

** The case is by the testing on Flatfish devices. It might not be able to reproduce on other mobile devices **

Gaia:     4a0bb67204572affcbf1afb384d2ffdc8261e977
Gecko:    e42dac2ae79959eadd8d832c715e430ada8d64cc
BuildID   20131108064537
Version   28.0a1
Update correct commit number. Due to there's local patch for Flatfish now, the commit numbers in description didn't fulfill exist commit numbers.

GECKO_REV=33e7bec8e5daa5acb2be3c4fb1deca3eade0d142
GAIA_REV=b4e34df2b2e6249723d239d90f8cf6e4c769a6bc
GECKO_BRANCH=mozillaorg/master
GAIA_BRANCH=mozillaorg/master
BUILD_TAG=jenkins-B2G.master.flatfish-38
BuildID=20131108064537
Component: Gaia::System → Gaia::System::Window Mgmt
Blocks: flatfish
George, I think you've investigated this behavior, could you elaborate more about it?
Flags: needinfo?(gduan)
Attached file PR to master
Hi David,
I planed to solve it in bug 928254, but I think that bug is not so quick to complete reviewing. So, I submit this patch here.
Please kindly check.
Thanks.
Attachment #830564 - Flags: review?(dflanagan)
Flags: needinfo?(gduan)
Assignee: nobody → gduan
blocking-b2g: 1.3? → 1.3+
Comment on attachment 830564 [details]
PR to master

Looks good to me.

In the future, you don't have to wait for my review of small CSS changes like this. Feel free to find someone locally to do the review. Especially when the bug only affects form factors that I can't test on!
Attachment #830564 - Flags: review?(dflanagan) → review+
No problem, thank you,
merge into master,
https://github.com/mozilla-b2g/gaia/commit/f4567b5cb9b4ecf1a7bb3ac113f000fb96fac1bb
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.