[Flatfish] Can Not exit to Home from "No recent apps" of Task Manager message

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: RaymondSu, Assigned: gduan)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:1.3+)

Details

(Whiteboard: [Flatfish only][developer+])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.101 Safari/537.36

Steps to reproduce:

1. Swipe two fingers upward to launch Task Manager screen shoots.
2. Terminate all Apps showing by Task Manager until exit to Home
3. Swipe two finger upward to launch Task Manager screen again.
4. See "No recent apps" message text on the screen
5. No way to exit this message until sleep/wakeup cycle
(one finger upward swiping is not working)



Expected results:

Should be able to exit this message by "back" or "OK" dialog box.
(Reporter)

Updated

5 years ago
Blocks: 903304
blocking-b2g: --- → 1.3?
Whiteboard: Flatfish

Updated

5 years ago
Component: General → Gaia::System::Window Mgmt
This is a regression of bug 919492. Z-index has been modified lower than some doms in system.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 830605 [details]
PR to master

Hi Alive,
this bug is properly a regression of bug 919492.
I raise z-index of bottom panel in JS instead in zindex.css because I'm not quite sure if we'll use bottom panel for other purpose in the future (maybe haida? ). Please let me know if you have any concern.
Thanks.
Assignee: nobody → gduan
Comment on attachment 830605 [details]
PR to master

r- for hardcode z-index in the javascript.
Attachment #830605 - Flags: review-
Comment on attachment 830605 [details]
PR to master

Hi Alive,
thanks for advice,
could you kindly check it again?
Attachment #830605 - Flags: review- → review?(alive)
Comment on attachment 830605 [details]
PR to master

Dislike overload screen element
See https://bugzilla.mozilla.org/show_bug.cgi?id=919492#c6
Attachment #830605 - Flags: review?(alive)
Comment on attachment 830605 [details]
PR to master

Hi Alive,

thanks for your patience. Patch is updated, please kindly check.
Attachment #830605 - Flags: review?(alive)

Updated

5 years ago
blocking-b2g: 1.3? → 1.3+
Whiteboard: Flatfish → [Flatfish only][developer+]
Attachment #830605 - Flags: review?(alive) → review+
Thanks, Alive,
merge into master,
https://github.com/mozilla-b2g/gaia/commit/3a3fb375a20dea86029be90dd0789bf90b2eef6d
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.