[e10s] Paint Flashing tool needs to be remotable

RESOLVED FIXED

Status

defect
RESOLVED FIXED
6 years ago
Last year

People

(Reporter: rcampbell, Unassigned)

Tracking

(Blocks 1 bug)

unspecified
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(e10s+)

Details

(Whiteboard: [e10s-m7])

This is blocking e10s
Mass tracking-e10s flag change. Filter bugmail on "2be0fcce-e36a-4e2c-aa80-0e3d33eb5406".
tracking-e10s: --- → +
These DevTools bugs should probably block e10s from riding to Aurora.
harthur says these DevTools bugs are not Aurora blockers for e10s.
Whiteboard: [e10s-m7]
The new rect highlighter introduced in bug 1076866 could be used. This could also be a good next bug for new contributors.

Paul, Patrick, are you able to mentor this ?
Flags: needinfo?(pbrosset)
Flags: needinfo?(paul)
Paul knows this code better so he might correct me if I'm wrong, but here's what I think:

The code that draws the painted rectangles in the page is in gecko, in c++, I don't think we want to replace this with the new rect highlighter. What we need to do to make this remotable though is make sure the paintflashing gcli command works remotely (toolkit/devtools/gcli/commands/paintflashing.js).
Flags: needinfo?(pbrosset)
No, we don't want to use the highlighter for that.
We need an actor (or leverage an existing actor) to expose nsIDOMWindowUtils.paintFlashing.
Flags: needinfo?(paul)
Paul, the etherpad at https://etherpad.mozilla.org/devtools-e10s-statuses says that this bug is assigned to you, but the bug isn't assigned to you. Are you still planning to work on this in the near future?
Flags: needinfo?(paul)
(In reply to Eddy Bruel [:ejpbruel] from comment #7)
> Paul, the etherpad at https://etherpad.mozilla.org/devtools-e10s-statuses
> says that this bug is assigned to you, but the bug isn't assigned to you.
> Are you still planning to work on this in the near future?

No.
Flags: needinfo?(paul)
Duplicate of this bug: 1142368
This should be fixed as part of the command line remoting in bug 1128988
Summary: Paint Flashing tool needs to be remotable → [e10s] Paint Flashing tool needs to be remotable
This now works for me on Nightly and DevEdition as of August 10th. Feel free to reopen if I'm wrong.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.