Closed Bug 937913 Opened 6 years ago Closed 5 years ago

Intermittent TEST-UNEXPECTED-FAIL | browser_dbg_search-global-04.js | leaked until shutdown [nsGlobalWindow {#9971,#9973} doc_script-switching-01.html

Categories

(DevTools :: Debugger, defect)

x86_64
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: KWierso, Unassigned)

References

Details

(Keywords: intermittent-failure)

https://tbpl.mozilla.org/php/getParsedLog.php?id=30495792&tree=Mozilla-Inbound
slave: talos-mtnlion-r5-083

Similar to bug 937912, which happened a few pushes after this failure occurred...


14:52:47     INFO -  INFO TEST-END | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/xpinstall/browser_whitelist6.js | finished in 206ms
14:52:47     INFO -  TEST-INFO | checking window state
14:52:53  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_search-global-04.js | leaked until shutdown [nsGlobalWindow #9971 http://example.com/browser/browser/devtools/debugger/test/doc_script-switching-01.html]
14:52:53  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_search-global-04.js | leaked until shutdown [nsGlobalWindow #9973 http://example.com/browser/browser/devtools/debugger/test/doc_script-switching-01.html]
14:52:53     INFO -  INFO TEST-START | Shutdown
14:52:53     INFO -  Browser Chrome Test Summary
14:52:53     INFO -  	Passed: 57294
14:52:53  WARNING -  	Failed: 2
14:52:53  WARNING -  One or more unittests failed.
14:52:53     INFO -  	Todo: 48
14:52:53     INFO -  *** End BrowserChrome Test Results ***
14:52:53     INFO -  ************************************************************
14:52:53     INFO -  * Call to xpconnect wrapped JSObject produced this error:  *
14:52:53     INFO -  [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/modules/identity/Identity.jsm :: shutdown :: line 78"  data: no]
14:52:53     INFO -  ************************************************************
14:52:53     INFO -  *** WIFI GEO: shutdown called
14:52:53     INFO -  JavaScript strict warning: resource://gre/modules/Log.jsm, line 484: reference to undefined property message.level
14:52:53     INFO -  NOTE: child process received `Goodbye', closing down
14:52:54     INFO -  INFO | runtests.py | Application ran for: 0:26:28.273269
14:52:54     INFO -  INFO | zombiecheck | Reading PID log: /var/folders/pl/7jkwsdl50mdgrfpv21byfpzc00000w/T/tmpO82Qg3pidlog
14:52:54     INFO -  WARNING | leakcheck | refcount logging is off, so leaks can't be detected!
14:52:54     INFO -  runtests.py | Running tests: end.
Blocks: 933882
Blocks: 942102
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 941787
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Closing bugs where TBPLbot has previously commented, but have now not been modified for >3 months & do not contain the whiteboard strings for disabled/annotated tests or use the keyword leave-open. Filter on: mass-intermittent-bug-closure-2014-07
Status: REOPENED → RESOLVED
Closed: 6 years ago5 years ago
Resolution: --- → WORKSFORME
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.