Closed Bug 938287 Opened 6 years ago Closed 6 years ago

[User Story] Ability to Edit Homescreen Bookmarks

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
1.4 S3 (14mar)

People

(Reporter: pdol, Unassigned)

References

Details

(Keywords: feature, Whiteboard: [ucid:System108, 1.4:P2, ft:systems-fe][systemsfe])

Attachments

(1 file)

User Story:
As a user, I want to be able to edit bookmarks that I add to the homescreen so that I can modify bookmarks that have already been created, instead of having to delete the bookmark and creating a new one.

Acceptance Criteria:
1. I can choose to edit a homescreen bookmark and am able to change the page title as well as the address.
2. Changing the page title or address results in the bookmark being updated after I finish editing.
3. I can only edit bookmarks.  Other app names cannot be edited.
Flags: in-moztrap?(nhirata.bugzilla)
Proposed UX wireframes for this user story
No longer blocks: 1.3-systems-fe
Blocks: 945827
Whiteboard: [ucid:System108, 1.3:P2, ft:systems-fe] → [ucid:System108, 1.4:P2, ft:systems-fe]
Would we need to be able to differentiate the difference between a homescreen bookmark and an app?  or are we able to edit the title of any app/homescreen/collection?
Keywords: feature
Duplicate of this bug: 962616
Component: Gaia::System → Gaia::Homescreen
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Depends on: 964337
Assignee: crdlc → nobody
No longer depends on: 964337
Depends on: 964337
Whiteboard: [ucid:System108, 1.4:P2, ft:systems-fe] → [ucid:System108, 1.4:P2, ft:systems-fe][systemsfe]
Target Milestone: --- → 1.4 S1 (14feb)
QA Contact: rafael.marquez
Target Milestone: 1.4 S1 (14feb) → 1.4 S2 (28feb)
blocking-b2g: --- → 1.4?
blocking-b2g: 1.4? → ---
Rafael mentioned offline that he'll be taking this.
Flags: in-moztrap?(nhirata.bugzilla) → in-moztrap?(rafael.marquez)
No longer blocks: 1.4-systems-fe
Flags: in-moztrap?(rafael.marquez)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #2)
> Would we need to be able to differentiate the difference between a
> homescreen bookmark and an app?  or are we able to edit the title of any
> app/homescreen/collection?

Hi Naoki, 

The proposal only applies to bookmarks on the home screen.
Flags: needinfo?(fdjabri)
Target Milestone: 1.4 S2 (28feb) → 1.4 S3 (14mar)
Patch implemented in bug 964337
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Blocks: 1.4-systems-fe
No longer blocks: 2.0-systems-fe
Flags: in-moztrap?(rafael.marquez)
Verified in master branch (1.4)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.