Memory leaks from slow start to full use after 10minutes

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: will583, Assigned: asa)

Tracking

({memory-leak, perf})

Trunk
x86
Linux
memory-leak, perf
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3+) Gecko/20010805
BuildID:    2001080506

After about 5 to 10 minutes it gets really jerky and extreemly slow from surfing. 

Reproducible: Always
Steps to Reproduce:
1.Logon
2.connect to the net
3.start up Mozilla which aslo starts mailer
4.Use for a while, have about 3 windows open

Actual Results:  Totally slow and jerky. have to shut down Mozilla and restart
or use opera after i've lost my patience.

Expected Results:  Smooth constant running much like I get from Opera.

MD 7.2
PII 450 64mb ram
128 mb swap
(Assignee)

Comment 1

17 years ago
I'm not experiencing this problem at all in mozilla 080608 linux build. I'm also
not experiencing this with 0.9.3.
(Reporter)

Comment 2

17 years ago
I was using it again last night and it has to be mozilla although I should not 
have said surfing in my original post but changing windows or desktops or start 
up say Konqueror to access a directory.

Last night about half an hour in things just got so slow that on shutting down 
mozilla and starting Opera things got better, Opera started in twice the time 
it normally takes but the system responded a lot better. To get the system back 
to normal I had to log out and log back in.

Comment 3

17 years ago
Not seeing it on Win2k with 0.9.3
However, my experience is that Moz easily eats 40 megs of ram or more with 3
windows open and after surfing even for a very short while. The
jerkiness/slowness is probably your system doing lots of swapping, since you
only have 64 megs of ram. Try stuffing some more memory in your machine and see
if the problem continues to exist (Hey, memory is cheap these days :)).

Comment 4

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Component: Browser-General → XPCOM
Ever confirmed: true
Keywords: mlk, perf
(Reporter)

Comment 5

17 years ago
Ok I have upgraded to 192 Mbs from 64 and so far for the past day Mozilla seems
fine.

I guess its not so much a bug but a system requirement that mozilla needs
probably 128Mb's ram to run smothly much like Netscape does.

O' well she's a memory hog.

Thanks for your help.

Updated

17 years ago
Blocks: 92580
marking worksforme after reporters comment.

Reporter: We know that mozilla use many RAM and we try to fix that....
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Updated

17 years ago
No longer blocks: 92580
You need to log in before you can comment on or make changes to this bug.