If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][FTU][UI] Checkboxes within WiFi and About Firefox OS panes overlap text

RESOLVED FIXED

Status

Firefox OS
Gaia::First Time Experience
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gbennett, Assigned: eeejay)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, firefox28 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 832652 [details]
2013-11-14-16-10-34.png

Description:
The "Show Password" checkbox overlaps text, but the checkbox itself is still functional. The "About Firefox OS" FTU pane checkbox is center justified overlapping text as well.

Repro Steps:
1) Updated Buri 1.3 mozRIL to BuildID: 20131114143149
2) In FTU select an available WiFi network
3) Observe "Show Password" check
4) Go to "About Firefox OS" pane and observe checkbox on that pane

Actual:
Checkboxes overlaps text.

Expected:
No overlapping occurs and checkboxes appears properly.

Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131114143149
Gaia: 4ea5adac92d6a9ab035e708e941d50be0d670da2
Gecko: 7b014f0f3b03
Version: 28.0a1
Firmware Version: 20131104

Notes: I was not able to get an image of the FTU WiFi Show Password checkbox as when you screenshot that pane it captures the "Select a network" pane instead for some reason (I'm going to write a bug on that tomorrow).

Repro frequency: 100%, 4/4
See attached: 2013-11-14-16-10-34.png
Related to bug: https://bugzilla.mozilla.org/show_bug.cgi?id=929565
That's going to be silly to ship with overlapping checkbox over text on the FTE
blocking-b2g: --- → 1.3?
Keywords: regressionwindow-wanted

Updated

4 years ago
QA Contact: sparsons

Comment 2

4 years ago
This issue started to occur on the Buri 1.3 Build ID: 20131114143149

Gaia   4ea5adac92d6a9ab035e708e941d50be0d670da2
SourceStamp 7b014f0f3b03
BuildID 20131114143149
Version 28.0a1

Last working on Buri 1.3 Build ID: 20131113040200

Gaia   7243b75041c93bc7deb240131748d0b164f3f0b0
SourceStamp 7b014f0f3b03
BuildID 20131113040200
Version 28.0a1
Keywords: regressionwindow-wanted
yet another regression from bug 914892
Blocks: 914892
(Assignee)

Updated

4 years ago
Assignee: nobody → eitan
(Assignee)

Comment 4

4 years ago
Created attachment 833247 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/13762

Pointer to Github pull-request
(Assignee)

Updated

4 years ago
Attachment #833247 - Flags: review?(etienne)
Comment on attachment 833247 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/13762

Forwarding to an FTU peer freshly back from PTO :)
Attachment #833247 - Flags: review?(etienne) → review?(fer.campo.garcia+bugzilla)
Duplicate of this bug: 939380
Duplicate of this bug: 939382
Duplicate of this bug: 939359
Comment on attachment 833247 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/13762

After checking the original bug 914892 to understand the changes, it looks good to me (only tested on nighlty, though)
Attachment #833247 - Flags: review?(fer.campo.garcia+bugzilla) → review+
(Assignee)

Comment 10

4 years ago
https://github.com/mozilla-b2g/gaia/commit/cf542fe79eeb9dd89968109f72442a285a02a754
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
blocking+ for layout regression
blocking-b2g: 1.3? → 1.3+
You need to log in before you can comment on or make changes to this bug.