[B2G][Settings][Wi-Fi] "Show Password" checkbox overlaps text

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gbennett, Assigned: joan)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(firefox27 fixed, b2g-v1.2 affected)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 820439 [details]
CheckboxOverlap.png

Description:
The "Show Password" checkbox overlaps the text itself, but the checkbox itself is still functional.

Repro Steps:
1) Updated Buri 1.3 master/mc mozRIL to BuildID: 20131022040242
2) Go to Settings app
3) Select Wi-Fi
4) Select an available network.
5) Observe "Show Password" check

Actual:
Checkbox overlaps "Show Password" text.

Expected:
No overlapping occurs.

Environmental Variables:
Device: Buri 1.3 master/mc mozRIL
BuildID: 20131022040242
Gaia: 50f544a7530c266aab9bbc9a893e00e15d34c02f
Gecko: 177bf37a49f5
Version: 27.0a1
Firmware Version: 20131015

Repro frequency: 100%, 3/3
See attached: CheckboxOverlap.png
Looks like a VD regression. Someone from the VD dev team might want to pick this up.
Keywords: regression, regressionwindow-wanted
(Reporter)

Updated

5 years ago
QA Contact: gbennett
(Reporter)

Comment 2

5 years ago
First Broken Build
Environmental Variables:
Device: Buri 1.3 master/mc mozRIL
BuildID: 20131018040217
Gaia: 18c2ab4b7b2d4cacee90fb85e97354142b2fad4a
Gecko: 855da6d8a327
Version: 27.0a1
Firmware Version: 20131015

Last Working Build
Environmental Variables:
Device: Buri 1.3 master/mc mozRIL
BuildID: 20131017040202
Gaia: 616e87af0133496620aea89f21ca5d37acedf466
Gecko: 423b9c30c73d
Version: 27.0a1
Firmware Version: 20131015
Keywords: regressionwindow-wanted

Updated

5 years ago
Duplicate of this bug: 930214

Comment 4

5 years ago
This issue is now reproducing on 1.2 as well.

Regression Window:

First Broken Build:
Environmental Variables:
Device: Buri v1.2 Mozilla RIL
BuildID: 20131023004005
Gaia: 1ca623e7a79a9653b54a45ef7f8bb03b8d7100fc
Gecko: bb33e2fe109c
Version: 26.0a2
Base Image: 20131015

Last Working Build:
Environmental Variables:
Device: Buri v1.2 Mozilla RIL
BuildID: 20131022004000
Gaia: 00d5964eabf95a6a8a632420dfa36fc76dcbc9b7
Gecko: 7453a764f9a9
Version: 26.0a2
Base Image: 20131015
status-b2g-v1.2: unaffected → affected

Updated

5 years ago
Blocks: 917704
Assignee: nobody → joan.leon
(Assignee)

Comment 5

5 years ago
Created attachment 823229 [details]
patch.html
Attachment #823229 - Flags: review?(arnau)
Comment on attachment 823229 [details]
patch.html

That looks great!
Attachment #823229 - Flags: review?(arnau) → review+
Merged (24609ad8d8c606f087714466dfc839c5734c1e68)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-firefox27: affected → fixed
(Reporter)

Comment 8

5 years ago
Created attachment 832644 [details]
CheckboxIssues.zip

Attached zip contains images of WiFi password checkbox missing and the "About Firefox OS" FTU pane checkbox center justified overlapping text. The FTU WiFi Show Password checkbox is overlapping text as well, but I was not able to get an image of it as when you screenshot that pane it captures the "Select a network" pane instead for some reason (I'm going to write a bug on that tomorrow).

Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131114143149
Gaia: 4ea5adac92d6a9ab035e708e941d50be0d670da2
Gecko: 7b014f0f3b03
Version: 28.0a1
Firmware Version: 20131104
(Reporter)

Updated

5 years ago
status-firefox28: --- → affected
(Reporter)

Comment 9

5 years ago
While similar, my prior statement is different enough to merit writing up a new bug (https://bugzilla.mozilla.org/show_bug.cgi?id=938931). Sorry for any inconvenience.
status-firefox28: affected → ---
You need to log in before you can comment on or make changes to this bug.