B2G NFC: NFC socket callback prints too much log.

RESOLVED FIXED in 1.3 Sprint 5 - 11/22

Status

Firefox OS
NFC
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: allstars, Unassigned)

Tracking

unspecified
1.3 Sprint 5 - 11/22
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

On devices without nfcd, like Unagi, emulator. ipc/nfc/Nfc.cpp will keep printing 

"OnConnectSuccess"
"OnConnectError"
"OnConnectSuccess"
"OnConnectError"
"OnConnectSuccess"
"OnConnectError"
Just filed Bug 939056 to discuss should we enable MOZ_NFC only for some dev-device.
As :gps said we should enable NFC only when the platform supports it, see [1],
duplicate this bug with Bug 939056

[1]: https://bugzilla.mozilla.org/show_bug.cgi?id=939056#c5
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 939056
Reopen this bug for Bug 939056 still needs to be discussed for a while, but this error message is pain for developers.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Updated

5 years ago
Assignee: nobody → allstars.chh
Comment on attachment 8335816 [details] [diff] [review]
Patch

Currently I enable the log message only when DEBUG flag is set.
Attachment #8335816 - Flags: review?(vyang)
Comment on attachment 8335816 [details] [diff] [review]
Patch

Review of attachment 8335816 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you.
Attachment #8335816 - Flags: review?(vyang) → review+
https://hg.mozilla.org/mozilla-central/rev/b27854cba9c2
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.3 Sprint 5 - 11/22
(Assignee)

Updated

4 years ago
Duplicate of this bug: 948266
You need to log in before you can comment on or make changes to this bug.