(edge-gestures) don't work after using cards view

RESOLVED DUPLICATE of bug 962355

Status

RESOLVED DUPLICATE of bug 962355
5 years ago
5 years ago

People

(Reporter: zcampbell, Assigned: kgrandon)

Tracking

unspecified
Other
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

5 years ago
On 13th November nightly build.

Regression range unknown

STR
1. enable edge gestures
2. Launch 2 apps
3. Swipe to check edge gestures works
4. Open cards view
5. Back into app
6. Try edge gesture

Updated

5 years ago
Blocks: 918792
blocking-b2g: --- → 1.3?
Whiteboard: [systemsfe]
Depends on: 935260

Updated

5 years ago
blocking-b2g: 1.3? → 1.3+

Comment 1

5 years ago
george, does it related to bug 937039?
Flags: needinfo?(gduan)
Hi Zac,
if you're saying that gesture doesn't work in cardview, please try build after 11/11. I think I already fixed in bug 937039.
thanks.
Flags: needinfo?(gduan) → needinfo?(zcampbell)
(Reporter)

Comment 3

5 years ago
George, not *in* cards view, *after* cards view.

I just tried this again on today's nightly and it is not resolved.
Flags: needinfo?(zcampbell)
sorry, I thought it's a problem of homegesture panel on the bottom, but actually it's left/right panel for switching apps.
 I just reset gaia to Bug 919492, and found the bug is still there, so I guess it's regression of it.

Hi Etienne,
do you have any idea?
Flags: needinfo?(etienne)
This is not a regression.
The edge gestures never worked after using the card view.

The app edge gestures are de-activated (as they should) when we enter the cardview, but the current implementation of the card view does not trigger the right event when we go back to an app.
So the edge wont be active again until you go to homescreen and then to an app.

It should be tackled as part of bug 939809.
Flags: needinfo?(etienne)

Updated

5 years ago
Summary: Edge gestures don't work after using cards view → (edge-gestures) don't work after using cards view

Updated

5 years ago
Blocks: 941953

Updated

5 years ago
No longer blocks: 941953
edge gestures has been moved out of scope for 1.3, so we don't need to block on this.
blocking-b2g: 1.3+ → -

Updated

5 years ago
Duplicate of this bug: 962355
(Assignee)

Comment 8

5 years ago
I would like to take as I have a fix already in bug 962355.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Duping the other direction per Kevin's feedback.
No longer blocks: 918792
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
No longer depends on: 935260
Resolution: --- → DUPLICATE
Duplicate of bug: 962355
You need to log in before you can comment on or make changes to this bug.