Closed Bug 939643 Opened 6 years ago Closed 6 years ago

Intermittent browser_blocklist.js | Found an unexpected Addons:Blocklist at the end of test run

Categories

(Firefox Graveyard :: SocialAPI, defect)

x86
Linux
defect
Not set

Tracking

(firefox26 unaffected, firefox27 unaffected, firefox28 fixed, firefox-esr24 unaffected)

RESOLVED FIXED
Firefox 28
Tracking Status
firefox26 --- unaffected
firefox27 --- unaffected
firefox28 --- fixed
firefox-esr24 --- unaffected

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=30674890&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound debug test mochitest-browser-chrome on 2013-11-17 16:43:13 PST for push 095e5b582f53
slave: talos-r3-fed-101

17:06:36     INFO -  INFO TEST-END | chrome://mochitests/content/browser/browser/base/content/test/social/browser_blocklist.js | finished in 5204ms
17:06:36     INFO -  TEST-INFO | checking window state
17:06:36  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/social/browser_blocklist.js | Found an unexpected Addons:Blocklist at the end of test run
Mark or Shane, does one of you have some time to take a look at this relatively-recent regression?
It looks like, for some reason, the blocklist window isn't getting focus in some cases.  Also, the existing unload handler must be firing - but may well be firing for about:blank unloading before the real content is loaded.

The test doesn't really need to wait for focus, so this patch tweaks it to (a) wait for load before closing it and (b) don't add the unload handler until load has fired.

Test passes locally and a Linux only try is at https://tbpl.mozilla.org/?tree=Try&rev=7b4d4d5c3f99, which I'll re-trigger a few times.

Seeing I'm such an optimist, I'm assuming this will fix it, so asking Shane for review.
Attachment #8338163 - Flags: review?(mixedpuppy)
My patch in bug 931864 seems to change timing/scheduling enough to make this failure much more frequent.  Fortunately, the posted patch seems to fix the problem!  Nice!
Blocks: 931864
Comment on attachment 8338163 [details] [diff] [review]
0001-Bug-939643-avoid-test-orange-by-rejigging-how-we-wai.patch

lgtm
Attachment #8338163 - Flags: review?(mixedpuppy) → review+
https://hg.mozilla.org/integration/fx-team/rev/8737eca5b787
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/8737eca5b787
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 28
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.