Closed Bug 939890 Opened 6 years ago Closed 6 years ago

Don't build iLBC/G722/iSAC audio codecs for webrtc

Categories

(Core :: WebRTC, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla29
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- fixed

People

(Reporter: jesup, Assigned: glandium)

References

Details

Attachments

(1 file, 3 obsolete files)

While we don't use the optional audio codecs in WebRTC in Mozilla, we build the code for them even if they're not configured on in webrtc_config.gypi.

This isn't a huge problem and avoids inadvertent regressions, except that a) if the linker doesn't remove them for no references, we might waste a little space, b) it takes a (small) amount of time to compile them, but most importantly c) if I make a debug build for B2G on Linux, the compiler fails with an internal compiler error building the iSAC neon optimizations.

So, better to fully remove them if they're not configured on.
This is now blocking bug 949334.
Blocks: 949334
Attachment #8346814 - Attachment is obsolete: true
This is based on your patch, with audio_coding_sources figured.
Attachment #8346937 - Flags: review?(rjesup)
Assignee: rjesup → mh+mozilla
Status: NEW → ASSIGNED
Attached patch Disable compiling unused codecs (obsolete) — Splinter Review
works with <@(sources) now.  However, turning on iLBC or other codecs will fail in link due to lack of including libiLBC.a.desc for example.  That can be dealt with later in a different bug, though, as that issue already existed.
Attachment #8346836 - Attachment is obsolete: true
Comment on attachment 8346937 [details] [diff] [review]
Don't build iLBC/G722/iSAC audio codecs for webrtc

Review of attachment 8346937 [details] [diff] [review]:
-----------------------------------------------------------------

your solution was better....  Note that I think actually enabling other codecs causes link errors, but I think that was already the case.

::: media/webrtc/trunk/webrtc/modules/audio_coding/main/source/audio_coding_module.gypi
@@ +77,5 @@
>          'acm_generic_codec.cc',
>          'acm_generic_codec.h',
>          'acm_neteq.cc',
>          'acm_neteq.h',
>  # cheat until I get audio_coding_sources to work

remove comment
Attachment #8346937 - Flags: review?(rjesup) → review+
Attachment #8347379 - Attachment is obsolete: true
(In reply to Randell Jesup [:jesup] from comment #5)
> Created attachment 8347379 [details] [diff] [review]
> Disable compiling unused codecs
> 
> works with <@(sources) now.  However, turning on iLBC or other codecs will
> fail in link due to lack of including libiLBC.a.desc for example.  That can
> be dealt with later in a different bug, though, as that issue already
> existed.

Bug 949334 will take care of this :) (but as of now it breaks windows builds :( )
https://hg.mozilla.org/mozilla-central/rev/0044fa6c7fda
https://hg.mozilla.org/mozilla-central/rev/616533049b4c
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Blocks: 970864
Bug 970864 needs this patch to fix the compiling error when enable B2G_NOOPT.
blocking-b2g: --- → 1.3?
(In reply to StevenLee[:slee] from comment #11)
> Bug 970864 needs this patch to fix the compiling error when enable B2G_NOOPT.

I think you meant to nominate this for tarako, as the bug referenced here is 1.3T?
blocking-b2g: 1.3? → 1.3T?
triage: 1.3T+ for tarako
blocking-b2g: 1.3T? → 1.3T+
You need to log in before you can comment on or make changes to this bug.