Closed Bug 940213 Opened 7 years ago Closed 6 years ago

Pressing ctrl+z when the location bar is focused loops through the URL of other open tabs instead of undoing

Categories

(Firefox :: Address Bar, defect)

3.0 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 630436

People

(Reporter: padenot, Unassigned)

Details

STR:
- Open a new tab (ctrl+t)
- Type something in the URL bar
- Hit ctrl+z to undo

Expected:
- The text is erased and the location bar is now empty

Actual:
- The text is replaced by the URL of an other tab, and pressing ctrl+z again multiple times loops to what seems to be the open tabs.

This is (at least) on Linux, I haven't got any other machine handy to test.
Is this really an Australis bug? Was this not an issue on the previous nightly/aurora?
Flags: needinfo?(paul)
I can't repro on release, not sure about other versions.
Flags: needinfo?(paul)
This is bizarre... but I have ran it through mozregression and it has existed since the beginning of mozregression builds hehe (2009-01-01).

It's most likely coming from the fact that we use the same textbox for all tabs, and just replace text text value when switching tabs.

STR:
Open two tabs in Firefox.
-- Tab 1: www.google.com
-- Tab 2: www.mozilla.org
Switch to tab 1.
Switch to tab 2.
Focus the location bar while on tab 2
Notice location shows www.mozilla.org
Hit Ctrl+Z

ER:
IDK, nothing? Maybe the location goes blank?

AR:
Location bar shows www.google.com
No longer blocks: australis-merge
Version: Trunk → 3.0 Branch
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 630436
You need to log in before you can comment on or make changes to this bug.