Closed Bug 940265 Opened 8 years ago Closed 7 years ago

Bookmarks popup menu changes position on mouse over

Categories

(Firefox :: Toolbars and Customization, defect)

28 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 29
Tracking Status
firefox29 --- verified

People

(Reporter: dmedvinsky, Assigned: mikedeboer)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [Australis:P3][investigate-fix-on-aurora][good first verify])

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131118094134

Steps to reproduce:

Firefox 28.0a1 (2013-11-18) on Linux
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:28.0) Gecko/20100101 Firefox/28.0

1. Click on the right half of bookmarks button in navigation toolbar.
2. Observe the popup menu position.
3. Move mouse downwards a little, so it hovers the popup menu.
4. Observe the popup menu position change.

See attached gif.


Actual results:

The menu kind of jumps a little.


Expected results:

Menu should stay static.
Component: Untriaged → Toolbars and Customization
Duplicate of this bug: 940279
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [Australis:P3]
The behavior depends on the location of the bookmarks menu in the tool bar.

* I created a new profile (bookmarks menu toward the right of the window). Moving the mouse over a bookmark caused a slight step to the right for the menu.
* I moved the bookmarks menu button to the far left. The menu jumps to the left.
See Also: → 941409
Duplicate of this bug: 953154
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
This *could* be fixed by bug 941409, but we should check to be sure.
Depends on: 941409
Whiteboard: [Australis:P3] → [Australis:P3][investigate-fix-on-aurora]
Now that bug 941409 has landed, are you able to reproduce this any more Dmitry?
Flags: needinfo?(dmedvinsky)
The "jumping" behavior occurred with the 28 January Nightly. With the 29 January Nightly I can't reproduce the jump, but the menu is positioned incorrectly--too high.
Ubuntu. I didn't see it on Windows, but that might be because I have more bookmarks on my Ubuntu system.
(In reply to Mike Conley (:mconley) from comment #5)
> Now that bug 941409 has landed, are you able to reproduce this any more
> Dmitry?

No, I'm unable to reproduce this anymore. Indeed, I tried it yesterday with Jan 28 build and it was still there, and today with Jan 29 it is fixed.

As for what B.J. Herbison says about incorrect positioning — I can't reproduce this. Maybe because I only have handful of bookmarks on the top level menu though.

Should we mark this resolved and open a new issue or continue the discussion here?
Flags: needinfo?(dmedvinsky)
I tested some more, the incorrect placement is related to the length of the bookmark list. I am also able to reproduce bug 941051 when the placement is incorrect. I'll add a comment there.

(I have no opinion on whether the issue should be tracked in one of these two bug reports or a new report.)
Ok, so bug 941409 fixed the original issue and the popup being too high is fixed by 941051, so let's close this bug.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Whiteboard: [Australis:P3][investigate-fix-on-aurora] → [Australis:P3][investigate-fix-on-aurora][good first verify]
[bugday-20140416]

Hi,

I was able to reproduce the issue with Firefox 28.0a1 (2013-11-19) on Linux, and I confirm that it's fixed in the latest beta: Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 ID:20140414143035 CSet: 3a4f085a6398

Cheers,
Francesca
Marking as verified as per comment 10.
Status: RESOLVED → VERIFIED
Just updated to Nightly 31.0a1 (2014-04-16) and I get this funny behavior that the bookmarks popup doesn't appear at all. Same for downloads popup.

Sometimes it blinks for a jiffy and then disappears. Moreover, it actually is there and if I click at the area it is supposed to be, the click is fired for the popup, so if there is a bookmark in that place, it gets opened. Also, if I (accidentally) hover the bookmarks directory, the submenu is displayed.
(In reply to Dmitry Medvinsky from comment #12)
> Just updated to Nightly 31.0a1 (2014-04-16) and I get this funny behavior
> that the bookmarks popup doesn't appear at all. Same for downloads popup.

This issue is being tracked in bug 994562.
You need to log in before you can comment on or make changes to this bug.