[B2G][Browser][YouTube] Videos are cut off outside of the action safe area

RESOLVED FIXED

Status

Tech Evangelism
Preinstalled B2G Apps
P2
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gbennett, Assigned: fzzzy)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(firefox28 affected, b2g18 affected, b2g-v1.2 affected)

Details

(Whiteboard: burirun1.3-1)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8334591 [details]
YoutubeTitleSafe.zip

Description:
Videos are moved to the right making a black bar on the left side of the video area.

Repro Steps:
1) Updated Buri 1.3 mozRIL to BuildID: 20131119040204
2) Open browser app
3) Go to youtube.com
4) Select a video

Actual:
Video is off center to the right.

Expected:
Video appears properly within the title safe.

Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131119040204
Gaia: 4ecbc106a3fcf72cbd6dd8a43c46de7bacbedf20
Gecko: ba9ecdea3a90
Version: 28.0a1
Firmware Version: 20131104

Repro frequency: 100%
See attached: YoutubeTitleSafe.zip
Does this reproduce on 1.1?
Component: Gaia::Browser → General
Keywords: qawanted

Comment 2

4 years ago
This bug reproduces on 1.1 as well. The video is off center to the right when selecting a video on youtube.com.

Device: Leo v1.1 MOZ RIL
BuildID: 20131030041204
Gaia: 39b0203fa9809052c8c4d4332fef03bbaf0426fc
Gecko: 41c15ddb7216
Version: 18.0
Firmware Version: V10d
status-b2g18: --- → affected
Keywords: qawanted
QA Contact: nkhristoforov

Comment 3

4 years ago
Created attachment 8335426 [details]
1.1 Screenshot
That confirms this is likely a TE issue.
Blocks: 871910
Component: General → Mobile
Product: Firefox OS → Tech Evangelism

Updated

4 years ago
Component: Mobile → Preinstalled B2G Apps

Comment 5

4 years ago
Reproduced on a Huawei FFOS v1.1
Assignee: nobody → dpreston
Status: NEW → ASSIGNED

Updated

4 years ago
Priority: -- → P2

Comment 6

4 years ago
YouTube reviewing. Will come back with a date.

Updated

4 years ago
Summary: [B2G][Browser][YouTube] Videos are off center to the right out of the title safe → [B2G][Browser][YouTube] Videos are off center to the right
(Reporter)

Comment 7

4 years ago
Does the term title safe not apply to mobile devices?
(Assignee)

Comment 8

4 years ago
What does title safe mean?
(Reporter)

Comment 9

4 years ago
(In reply to Donovan Preston [:fzzzy] from comment #8)
> What does title safe mean?

The title-safe area is a rectangular area which is far enough in from the four edges, such that text or graphics show neatly: with a margin and without distortion. This area will be seen by all television screens, no matter when they were made, unless the user has modified the settings.

I've used it in the past when testing and bugging out-of-screen issues with devices/TV's, but for this situation I should have said "action safe" as that's more representative of screens that do not have rounded edges (most LCD/LED devices).
(Reporter)

Updated

4 years ago
Summary: [B2G][Browser][YouTube] Videos are off center to the right → [B2G][Browser][YouTube] Videos are cut off outside of the action safe area

Updated

4 years ago
Duplicate of this bug: 943689
Any updates on this bug? I've tested it on Leo and Helix and in both the video is moved to the right both in portrait and landscape mode
(Assignee)

Comment 12

4 years ago
We let YouTube know, waiting on their response.

Comment 13

4 years ago
Reproduced on:
-ZTE v1.1 build 20130820074633 platform 18.1
-Helix v1.1hd build 20131106012238 platform 18.1
(Assignee)

Comment 14

4 years ago
They are working on it.
Whiteboard: burirun1.3-1
(Assignee)

Comment 15

4 years ago
YT has now fixed this. I tested on Helix 1.1HD and TCL 1.1.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.