[B2G][Cost Control][Usage] Mobile and Wi-Fi checkboxes are left justified

RESOLVED FIXED

Status

Firefox OS
Gaia::Cost Control
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gbennett, Assigned: eeejay)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, firefox28 affected, b2g-v1.2 unaffected, b2g-v1.3 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8334773 [details]
UsageCheckbox.zip

Description:
The checkboxes within Usage are on the left side overlapping the variable color box instead of properly on the right side.

Repro Steps:
1) Updated Buri 1.3 mozRIL to BuildID: 20131119040204
2) Open Usage app and go through setup
3) On the usage tracking pane observe checkbox placement

Actual:
Mobile and Wi-Fi usage checkboxes are left justified overlapping variable color representation.

Expected:
Checkboxes are right justified causing no overlap.

Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131119040204
Gaia: 4ecbc106a3fcf72cbd6dd8a43c46de7bacbedf20
Gecko: ba9ecdea3a90
Version: 28.0a1
Firmware Version: 20131115

Repro frequency: 100%
See attached: UsageCheckbox.zip (Contains 1.3 repro and 1.2 not repro)
(Reporter)

Comment 1

4 years ago
Regression window:

Last working build ( Does NOT Reproduce)
Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131113040200
Gaia: 7243b75041c93bc7deb240131748d0b164f3f0b0
Gecko: 7b014f0f3b03
Version: 28.0a1
Firmware Version: 20131115

First Broken (Reproduces)
Environmental Variables:
Device: Buri 1.3 mozRIL
BuildID: 20131114143149
Gaia: 4ea5adac92d6a9ab035e708e941d50be0d670da2
Gecko: 7b014f0f3b03
Version: 28.0a1
Firmware Version: 20131115
Another fallout from bug 914892
Blocks: 914892

Updated

4 years ago
Keywords: regression

Updated

4 years ago
blocking-b2g: --- → 1.3?
(Assignee)

Updated

4 years ago
Assignee: nobody → eitan
(Assignee)

Comment 3

4 years ago
Bug #941246 is preventing me from coming up with a quick fix for this. Once I actually see this on a device or in Firefox, it will be easier.
traige: regression 1.3+
blocking-b2g: 1.3? → 1.3+
Also to note, that the checkboxes in 1.3 shows a double checkbox.  a black box and a blue checkbox.  (Look closely at the 1.3 image and you can see the black border on the right side)
(Assignee)

Comment 6

4 years ago
Created attachment 8349533 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/14814

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug #914892
[User impact] if declined: The checkboxes will align to the left and will cover the color legend for the data graph, as shown in the STR above.
[Testing completed]: Yes, on a ZTE Open
[Risk to taking this patch] (and alternatives if risky): Not much risk
[String changes made]: None
Attachment #8349533 - Flags: review?(21)
Attachment #8349533 - Flags: approval-gaia-v1.3?(21)
Comment on attachment 8349533 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/14814

No need for approval since it is 1.3+.
Attachment #8349533 - Flags: approval-gaia-v1.3?(21)
Attachment #8349533 - Flags: review?(21) → review?(salva)
Comment on attachment 8349533 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/14814

Harmless modification. Thank you a lot!
Attachment #8349533 - Flags: review?(salva) → review+

Updated

4 years ago
Duplicate of this bug: 956874
(Assignee)

Comment 10

4 years ago
https://github.com/mozilla-b2g/gaia/commit/f0ce4f4ef5ba10fd147fbed2a4eb5d0fc2e4324c
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Uplifted f0ce4f4ef5ba10fd147fbed2a4eb5d0fc2e4324c to:
v1.3: 16428e49b1489c5b064525670bbc2ef2d4bfb69d
status-b2g-v1.3: --- → fixed
You need to log in before you can comment on or make changes to this bug.