Pressing and releasing "Alt" opens the File menu, on Linux (when it should just reveal the menu bar)

RESOLVED DUPLICATE of bug 940040

Status

()

RESOLVED DUPLICATE of bug 940040
5 years ago
5 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:P4][Australis:M?])

(Reporter)

Description

5 years ago
STR:
 1. Be running a new build with Australis
 2. Press and release Alt.

ACTUAL RESULTS:
 Menu bar is revealed, and File menu is opened.
 [At this point if you press "v", it launches Print Preview]

EXPECTED RESULTS:
 Menu bar is revealed. File menu should *not* be opened.
 [At this point if you press "v", it opens View menu]


Nightly & IE11 show EXPECTED RESULTS on Windows 8.1.
Nightly shows ACTUAL RESULTS on Linux.
(Reporter)

Comment 1

5 years ago
(In reply to Daniel Holbert [:dholbert] from comment #0)
> STR:
>  1. Be running a new build with Australis

(er by "new build" I meant "nightly build", of course)

To elaborate slightly on why this is annoying: Normally, when you navigate menus with "Alt", you get a chance to preview what the available keys are and what menu-items they'll activate.  e.g. if you hit Alt+V (simultaneously), you can see the menu and choose your next keypress accordingly. (say, "c" to select Character Encoding submenu, and then "m" to select More Encodings, etc.)

Currently on Linux Nightly, there is no way to get into this "Preview" mode for the top-level menus.
(Reporter)

Updated

5 years ago
Component: General → Menus
Whiteboard: [Australis:P4][Australis:M?]
(Reporter)

Updated

5 years ago
Blocks: 870032
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 940040
(Reporter)

Comment 3

5 years ago
Ah, right -- I should've made this block "australis-merge", not "australis".

But anyway, this is now duped to a bug that blocks "australis-merge", so I'll just clear the "blocks" field here entirely, so we don't end up with duplicate bugs in the dependency field on the australis-merge metabug.
No longer blocks: 870032, 939862
You need to log in before you can comment on or make changes to this bug.