Closed Bug 940797 Opened 7 years ago Closed 4 years ago

Panels should have a blur and semi-transparency on OS X

Categories

(Firefox :: Theme, defect)

28 Branch
All
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1348294

People

(Reporter: u448270, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: uiwanted, Whiteboard: [Australis:P5])

Attachments

(1 file)

Attached image safari-fx-bg.png
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_1) AppleWebKit/537.71 (KHTML, like Gecko) Version/7.0 Safari/537.71

Steps to reproduce:

When trying to show any Firefox popup in new UI, they feel unnatural to OS X.

For example, “downloads” or “customise” popups.

Take a look at the attached screenshot.


Actual results:

Popups don't have blur and semitransparent background


Expected results:

Popups must have blur and semitransparent background
Stephen, do we want to look like Safari's panels or stay with our own styling?

Did we even change the download panel background as part of Australis?
Component: Untriaged → Theme
Flags: needinfo?(shorlander)
Keywords: uiwanted
Hardware: x86 → All
Summary: Australis on OS X popups feel unnatural → Panels should have a blur and semi-transparency on OS X
Safari also seems to have a slight gradient and/or at least lighter colors which makes the panel look way more pleasant to the eye (and is the platform default, of course, so more consistency would be awesome). 

Please consider this, at least the lighter colors. Currently it's so gray-ish and that does not combine well with the current weather …
Blocks: 925284
The lighter color will be introduced for ALL panels on OSX when the patches in bug 878065 land. Is that enough to dupe this bug to that one?
Depends on: 878065
I don't think we need to try and match the native panels exactly. The blur behind the transparency would be a nice touch though. Last time I checked it didn't seem to be easily doable.
Flags: needinfo?(shorlander)
(In reply to Mike de Boer [:mikedeboer] from comment #3)
> The lighter color will be introduced for ALL panels on OSX when the patches
> in bug 878065 land. Is that enough to dupe this bug to that one?

Let's wait for this to land.
Whiteboard: [Australis:P5]
Paul, how does it look to you now?
Flags: needinfo?(paul)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Depends on: 968595
Bug 1348294 has a good summary of the current situation.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(paul)
Resolution: --- → DUPLICATE
Duplicate of bug: 1348294
You need to log in before you can comment on or make changes to this bug.