Closed Bug 767321 Opened 8 years ago Closed 6 years ago

Lighter arrow panel design

Categories

(Toolkit :: Themes, enhancement)

enhancement
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ge3k0s, Unassigned)

References

(Depends on 1 open bug, )

Details

(Keywords: meta, Whiteboard: [Australis:P-][Australis:M-])

Attachments

(1 file, 1 obsolete file)

Implement the Australis arrow panel design

Feature page : https://wiki.mozilla.org/Arrow_Panel_Redesign

Mockup : http://people.mozilla.com/~shorlander/files/feature-pages/panels.jpg
Depends on: 615476
Assignee: nobody → chlee
Attached patch WIP Mac OS X patch (obsolete) — Splinter Review
Attachment #638069 - Flags: ui-review?(shorlander)
Slightly updated patch. Updated the identity panel with a new encryption icon and fixed width.
Attachment #638069 - Attachment is obsolete: true
Attachment #638069 - Flags: ui-review?(shorlander)
Attachment #638482 - Flags: ui-review?(shorlander)
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Since this patch has landed on the UX branch panels look is broken on Windows. In fact is there already a patch for Windows ?
(In reply to Guillaume C. [:ge3k0s] from comment #3)
> Since this patch has landed on the UX branch panels look is broken on
> Windows. In fact is there already a patch for Windows ?

Screenshot of before and after?
I will try to post a screenshot later, but the main issues are misaligned text and no more different larry icon (only the grey one remains).

Concerning Mac OSX implementation, there are some things that should be improved :
-First the icons which I assume aren't finals (it still miss blue and green larry) and the lock should be open if the connection isn't encrypted.
-The arrows should touch the icon to which they are related (to avoid hijacking on page that provide false panels).
-The new "inset more" arrows look great, but when the panel is in the corner of the page the visual isn't pretty. The arrow should ideally always be in the middle of his related icon (star, globe or download icon).
Depends on: 759397
This patch needs to be broken up into manageable parts, each of which a separate bug should be filed on. The first step will be to bring OS X in line with Windows and Linux by making arrow panels gray rather than black and reducing the arrow size.
Assignee: chlee → nobody
Status: ASSIGNED → NEW
Component: Theme → Themes
Depends on: 765714, 764755
No longer depends on: 759397
Keywords: meta
Product: Firefox → Toolkit
QA Contact: theme → themes
Depends on: 771284
Depends on: 771297
Depends on: 771301
Depends on: 771305
Depends on: 771306
Depends on: 771308
So, I'm interested in seeing this to completion, and I just got a Windows build up so I can start working on that platform. I'm not quite sure how to approach this split patch process though since there's a lot of interdependencies (both in terms of code and visual consistency) and since it should include/parallel the changes here: https://bugzilla.mozilla.org/show_bug.cgi?id=764755 wherever appropriate. That's why I originally just developed a huge patch, but I agree that it's not practical for refining. Sorry about the the push to UX; it was my first code pushed and I forgot to test it first.

dao, were you planning on working on this bug (either on Windows or other platforms) more? If so, would you prefer if I step back? If not, any tips on approach?
Component: Themes → about:memory
Component: about:memory → Themes
Stephen still owes more detailed specs for Windows and Linux. No problem for the UX branch. Its purpose is to test new features (and sometimes things are broken e.g. current drag and drop implementation breaks on page behaviour).
Summary: Implement Australis Arrowpanel redesign → [meta]Implement Australis Arrowpanel redesign
Summary: [meta]Implement Australis Arrowpanel redesign → Implement Australis Arrowpanel redesign
What's the status of this for Linux and Windows ? Is there some mockups for various platforms ?
Attachment #638482 - Flags: ui-review?(shorlander)
Depends on: 577927
No longer depends on: 577927
Blocks: australis
I've never seen this associated with Australis and it's definitely not blocking the Australis release.
No longer blocks: australis
Summary: Implement Australis Arrowpanel redesign → Lighter arrow panel design
(In reply to Matthew N. [:MattN] from comment #10)
> I've never seen this associated with Australis and it's definitely not
> blocking the Australis release.

In fact this is part of Australis. From https://wiki.mozilla.org/Firefox/Features/Theme_Refinement_and_Evolution_%28Australis%29

> 3. Dependencies
>Arrow Panel Redesign 

But you're right it's clearly not blocking Australis phase one.
Summary: Lighter arrow panel design → Australis lighter arrow panel design
Blocks: australis
Depends on: 871155
Alias: australis-panels
Summary: Australis lighter arrow panel design → Australis arrow panel redesign
No longer blocks: australis-navbar
This is not part of Australis.
Alias: australis-panels
No longer blocks: australis
Summary: Australis arrow panel redesign → Lighter arrow panel design
As discussed on IRC nice to have for Australis v.2
Whiteboard: [Australis:M-]
Depends on: 874792
Whiteboard: [Australis:M-] → [Australis:P-]
Blocks: 925284
Whiteboard: [Australis:P-] → [Australis:P-][Australis:M-]
It seems like All Windows platforms are using the Windows 8 specific style.
This bug and all is dependencies seem to have been fixed elsewhere except bug 615476.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.