Closed Bug 940935 Opened 6 years ago Closed 6 years ago

Small Icons Option for Toolbar Customization not available anymore

Categories

(Firefox :: Toolbars and Customization, defect)

28 Branch
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: keul, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: regression)

There's no option to use small icons in the toolbar/address bar, resulting in less available space for displaying web pages due to the enormous margins.
Keywords: regression
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Keul125 from comment #0)
> There's no option to use small icons in the toolbar/address bar, resulting
> in less available space for displaying web pages due to the enormous margins.

Note that bug 873626 made the navigation toolbar even taller, so it's not just the removal of the small icons mode contributing to this.
Blocks: 873626, 863299
The idea they had, near as I can tell, is that it was convoluted to make every theme have two different themes for small and large icons. You could already make a new theme with different sized icons, and that theme would probably be better, so doing this for people who wanted smaller icons makes more sense. Personally, I don't disagree with this logic. I think the best way to deal with this would be to include in the official Firefox build a second default theme with smaller icons and much less screen space usage and let users optionally switch to it using the Add-ons Manger just like every other theme. (maybe even listing it in there by default but only downloading its assets on enabling)

Frankly, most users of small icons mode (like myself) would be largely appeased by just killing all the extra padding that's around everything. I don't see a reason to have more than a few pixels between the bottom of the address bar and the content area.
OS: Windows Vista → All
Hardware: x86 → All
Removing small icons mode was a deliberate design decision - please see bug 863299.

Users who are interested in reducing the size of the toolbars have a few options:

1) Use a userChrome.css to reduce the size of the toolbar and the toolbaritems
2) Use an add-on like https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer to regain small icons mode

At this point, I don't believe we're planning on putting small icons mode back into the core product.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1008767
You need to log in before you can comment on or make changes to this bug.