Closed Bug 941002 Opened 7 years ago Closed 7 years ago

Add Developer Tools button to menu default set

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 29

People

(Reporter: madhava, Assigned: jaws)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P2])

Attachments

(1 file)

Right now, the devtools button is not, by default, in the menu panel (you can add it in customization mode).

This makes sense given our standard inclusion criteria -- it's not used by a very wide audience. That said, this particular 2% audience is an extremely important one, and the developer tools are ones we want to showcase and promote.

We should add the Developer Tools button to the default set in the panel menu. I wouldn't remove anything we have so far -- all those others have earned their place. This will mean we go from a grid of 9 to a grid of 9 plus one more. We lose a bit on visual neatness, but I think it's worth it. This may even end up making more clear that you can add to the menu.
I would thing that adding the developer tools to the default menu for most users is probably not a good idea. Might I suggest instead detecting profiles that have some devtool related prefs set and auto-customizing it in on upgrade just for them?
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
We won't fixed this in bug 925507. I understand that we want people to find out about developer tools, but it seems we would be putting a useless tool for 98% of users in the menu.

I also think that the lack of symmetry will look awkward, and we have an obvious entrance in to customization right at the bottom of this menu.
Duplicate of this bug: 925507
(In reply to Jared Wein [:jaws] from comment #2)
> We won't fixed this in bug 925507. I understand that we want people to find
> out about developer tools, but it seems we would be putting a useless tool
> for 98% of users in the menu.

98% is a made up number :) In any case, mind share matters more than usage share for this particular feature, and our devtools are one of Firefox's preeminent features that we're trying to actively promote. It doesn't make sense to relegate it to tertiary UI.
OS: All → Mac OS X
Hardware: All → x86
Version: Trunk → unspecified
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
This may sound like a dumb question, but what's wrong with just asking? Stick a widget into the first run page that says "are you a web developer? yes, then here's some stuff".
(In reply to Dave Garrett from comment #5)
> This may sound like a dumb question, but what's wrong with just asking?
> Stick a widget into the first run page that says "are you a web developer?
> yes, then here's some stuff".

People who don't identify as web developers on one day may identify as web developers in the future.
(In reply to Jared Wein [:jaws] from comment #6)
Yep.



Better more generic solution to the discoverability issue filed as bug 941250.
FWIW, I +1 having this in the panel by default. I've been living with the Character Encoding button dangling at the bottom (since I worked on bug 865916) and I didn't find the lack of symmetry awkward at all.

My reason would also be to promote the DevTools more as to promote web literacy.
Whiteboard: [Australis:P2]
(In reply to Madhava Enros [:madhava] from comment #9)
> Right now, the devtools button is not, by default, in the menu panel (you
> can add it in customization mode).
> 
> This makes sense given our standard inclusion criteria -- it's not used by a
> very wide audience. That said, this particular 2% audience is an extremely
> important one, and the developer tools are ones we want to showcase and
> promote.
> 
> We should add the Developer Tools button to the default set in the panel
> menu. I wouldn't remove anything we have so far -- all those others have
> earned their place. This will mean we go from a grid of 9 to a grid of 9
> plus one more. We lose a bit on visual neatness, but I think it's worth it.
> This may even end up making more clear that you can add to the menu.

Do you have a preference as to where this item should go?
Flags: needinfo?(madhava)
Attached patch PatchSplinter Review
This patch adds the Developer Tools button as the last button on the panel.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attachment #8348991 - Flags: review?(bmcbride)
Comment on attachment 8348991 [details] [diff] [review]
Patch

Review of attachment 8348991 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/customizableui/src/CustomizableUI.jsm
@@ +150,5 @@
>        "fullscreen-button",
>        "find-button",
>        "preferences-button",
> +      "add-ons-button",
> +      "developer-button"

And here we see the benefit of a trailing comma in lists...
Attachment #8348991 - Flags: review?(bmcbride) → review+
Landed with the trailing comma added in,
https://hg.mozilla.org/integration/fx-team/rev/fc79fa2fd2e3
Flags: in-testsuite+
Depends on: 951487
Clearing needinfo on this bug as I've filed bug 951487 to take a look at the menu panel placements.
Flags: needinfo?(madhava)
Try push,
https://tbpl.mozilla.org/?tree=Try&rev=3ccfe24ff74b

Relanded with the tests fixed,
https://hg.mozilla.org/integration/fx-team/rev/77e83106be39
then promptly backed out because I made a typo on a last-minute change and didn't re-run the test locally,
https://hg.mozilla.org/integration/fx-team/rev/bdfe578d5f9f

Relanded with tests fixed and confirmed locally,
https://hg.mozilla.org/integration/fx-team/rev/92b41b6a875c
https://hg.mozilla.org/mozilla-central/rev/92b41b6a875c
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
You need to log in before you can comment on or make changes to this bug.