Generic share action tweaks

RESOLVED DUPLICATE of bug 940997

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 940997
5 years ago
4 years ago

People

(Reporter: lucasr, Unassigned)

Tracking

unspecified
All
Android
Points:
---

Firefox Tracking Flags

(fennec29+)

Details

(Reporter)

Description

5 years ago
The current generic share icon as the first item in the quick share row is not very intuitive. Two reasons:
1. We're not using the standard Android share icon.
2. It's not obvious that the icon will open a submenu.

Possible alternatives:

1. Simply replace the current icon with the standard Android icon for sharing.
2. Do 1, and move the generic icon to be the last (rightmost) in the list.
3. Show the right-arrow icon for submenus (i.e. the same used for the 'Tools' menu item) as the last (rightmost) item in the row.

I'm personally leaning torwards Option 3 as it 1) shows your top sharing apps first 2) communicates more clearly the 'see more' behaviour of the button.

If the right-arrow icon doesn't work well for some reason, Option 2 would be my second favourite.

Thoughts?
Option 3 that uses the "share" icon + submenu arrow ?
(Reporter)

Comment 2

5 years ago
(In reply to Mark Finkle (:mfinkle) from comment #1)
> Option 3 that uses the "share" icon + submenu arrow ?

Yeah, that could work as well. Up to Ian :-)
Flags: needinfo?(ibarlow)
tracking-fennec: ? → 28+
(Reporter)

Comment 3

5 years ago
We decided to revert FF28 to use the single quickshare UI (see bug 946233). Re-nominating.
tracking-fennec: 28+ → ?
tracking-fennec: ? → 29+

Updated

5 years ago
Duplicate of this bug: 947088
I think the design in bug 940997 covers this, now. Dupe?
(Reporter)

Comment 6

5 years ago
(In reply to Peter Retzer (:pretzer) from comment #5)
> I think the design in bug 940997 covers this, now. Dupe?

Yep. I originally considered we could work on these bugs separately but the design in bug 940997 covers everything.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 940997

Updated

4 years ago
Flags: needinfo?(ibarlow)
You need to log in before you can comment on or make changes to this bug.